Error parsing profile


#1

Ich habe eben durch Zufall folgenden Fehler im Protokoll gesehen.
Als zweiter Eintrag kommt dann noch “Mon Jan 08 19:02:36 CET 2018 Kein Installationsprofil gefunden. Läuft die Anwendung in der IDE?”

Die erwähnte .gz Datei konnte ich auch nicht mit 7zip öffnen, alle anderen Dateien im Verzeichnis jedoch schon.
Hat das irgendwelche negativen Auswirkungen oder einfach nur unschön?

Mon Jan 08 19:02:36 CET 2018
Error parsing profile C:\Users\_[...]_\Portfolio Performance\p2\org.eclipse.equinox.p2.engine\profileRegistry\DefaultProfile.profile\1515171616760.profile.gz.

java.util.zip.ZipException: Not in GZIP format

	at java.util.zip.GZIPInputStream.readHeader(Unknown Source)

	at java.util.zip.GZIPInputStream.<init>(Unknown Source)

	at java.util.zip.GZIPInputStream.<init>(Unknown Source)

	at org.eclipse.equinox.internal.p2.engine.SimpleProfileRegistry$Parser.parse(SimpleProfileRegistry.java:716)

	at org.eclipse.equinox.internal.p2.engine.SimpleProfileRegistry.restore(SimpleProfileRegistry.java:534)

	at org.eclipse.equinox.internal.p2.engine.SimpleProfileRegistry.getProfileMap(SimpleProfileRegistry.java:365)

	at org.eclipse.equinox.internal.p2.engine.SimpleProfileRegistry.internalGetProfile(SimpleProfileRegistry.java:249)

	at org.eclipse.equinox.internal.p2.engine.SimpleProfileRegistry.getProfile(SimpleProfileRegistry.java:179)

	at name.abuchen.portfolio.ui.update.UpdateHelper.<init>(UpdateHelper.java:50)

	at name.abuchen.portfolio.ui.addons.StartupAddon$1.run(StartupAddon.java:153)

	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

#2

Interessant… :thinking:

Ich habe keine Ahnung was das schief gegangen sein könnte. Ich vermute dass hat erst mal keine direkte Auswirkungen auf das Programm selber. Aber ich würde wetten, dass das Programm beim nächsten Update nicht per Online Aktualisierung aktualisiert werden kann. Vermutlich musst Du dann das ZIP noch mal komplett runterladen.


#3

Danke für die Antwort. Ich habe es jetzt noch mal vorsorglich komplett heruntergeladen und neu „installiert“, danach sind die Probleme verschwunden.