Probleme mit Eclipse


#1

Hallo,

trotz mehrfacher Versuche bekomme ich es einfach nicht hin PP in Eclipse zum laufen zu bringen.

Es scheint Probleme mit den Abhängigkeiten zu geben.

Eclipse
Version: Oxygen.2 (4.7.2)
Build id: M20171130-0510

auf MacOS

Ich bekomme immer die Fehlermeldung, dass die Abhängigkeiten in keinem Repository gefunden werden:

Das Eclipse ist komplett neu, nur für PP runtergeladen

  • Checkstyle configuration plugin for M2Eclipse|1.0.0.201705301746
  • Eclipse SDK|4.7.2.M20171130-0510
  • m2e - Maven Integration for Eclipse (includes Incubating components)|1.8.2.20171007-0217
  • Tycho Project Configurators|0.8.1.201704211436

#2

Hallo Elliot,

das sieht danach aus als ob die Target Platform noch nicht in Eclipse gesetzt wurde.

Wenn du diese mit Hilfe von mvn clean install -Dgenerate-target-platform=true generiert hast, kannst du in Eclipse im Projektordner portfolio-app/ide-target-platform und der Datei portfolio-ide.target diese Plattform dann einbinden.

Jetzt sollten die Fehler eigentlich verschwunden sein.

Gruß
Marco


#3

Hallo Ragas,

doch die auf GitHub beschriebenen Schritte habe ich durchgeführt.
14 libs werden auch in […]/ide-target-plattform/bundles gefunden

Gruß
Leif


#4

Gerade gesehen, lt. @AndreasB scheint es momentan Probleme mit den Abhängigkeitenin Eclipse zu geben:
Running target in eclipse