Import CSV file

I did not find a general suggestion thread for CSV Imports.
So here one issue I come across:
image

The format of numbers currently only identifies
0.000,00
0,000.00
0’000.00
but 0 000,00 not yet.

This new format would be useful for me at least as it then always just imports 1 if I use 0.000,00, but the value was 1 000.

This part of the forum is English. Can you add an English translation under your post?

The issue seems to be not having a recognised crypto currency. Can you also provide a sample csv record?

Hello
Thanks for your answer. I try to explain in english.
I’m trying to import a csv file for incoming distributions of my crypto account. I select “account transactions” and I see that there is an unassigned required field: value.
So I can’t click “next”!
But I do not have this field “value” since I receive CRO. The other fields are:
Transaction description for me is “card cashback” or “crypto earn”
Currency = currency
Amount = parts
Manually I do with “incoming distribution”, but it is restrictive and above all there is a risk of copying error.

Thanks in advance foryour help.
Regards.
Herewith the example file.
crypto_record_example.txt (502 Octets)

Supported currencies seem to be listed under General Data, Currencies. There is no CRO, presumably because it’s not in https://www.six-group.com/dam/download/financial-information/data-center/iso-currrency/lists/list_one.xls (see ISO 4217 - Wikipedia). #1633 mentions crypto support.

It is not a problem of crypto. It is more probably something I do not understand in the import of csv file. Maybe my question in not clear…
Thanks
Andre
PS: here a picture of my screen when I try to import…
csvin
I hope it can help to understand.

Amount should be associated with valeur, not parts.

I am not able to import transaction data from a CSV file even though all the fields appear to be properly mapped. Can any one help. I am running an iMac with MacOS High Sierra Version 10.13.16. As you can see on the attached file, the fields are green, I have tired chosing different options in the Type of Data but still I am not able to import (I do not get the Finish button to turn green).
CSV.pdf (56.5 KB)

Top of screen:

Unmapped required field(s): Value

Add transaction value.

Edit: Try Date, Type, Value where Type is “Fee”.

In addition to the comment from @flywire I suggest to export a demo transaction you want to import first. Then you have a template for the import.

That worked!!! :grinning: Thank you so much for your help.

1 Like

Is it possible to do this with some sort of Select All > Set provider to Yahoo > Update all?

I have imported 3 years of transactions, but the list is long. Lot of work to do it manually.

Firstly, if you think that would be a useful feature I’d encourage you to add a supporting emoji on the issue in GitHub.

When the data file is updated it will look like the following:

<client>
  <version>51</version>
  <baseCurrency>AUD</baseCurrency>
  <securities>
    <security>
      <uuid>831d8a3e-7025-4b0f-b6ca-3ef5bf727eb4</uuid>
      <name>REA Group Ltd</name>
      <currencyCode>AUD</currencyCode>
      <tickerSymbol>REA.AX</tickerSymbol>
      <feed>YAHOO</feed>
      <prices>

Try this and let us know how it goes.

This is totally not supported so backup your data file. Then open the data file with a text editor (eg np++ in Windows) before you add the providers.

It might be a search and replace of :

</tickerSymbol> 
     <prices>

with

</tickerSymbol>
      <feed>YAHOO</feed>
      <prices>

The image below shows the np++ Extended interface which uses a \n as new-line and the groups of 4 spaces are important:

image

1 Like

Thanks. Solved. :+1:t2:

noone else than me interested in this?

Because you should post it to Issues · buchen/portfolio · GitHub

Thank you for the extensive tut.

Question: If I already have my PF data all setup and running the way I want and import again data from PDF, Does it overrides what I already have or does it add to it?

This topic is csv but it recognises the pdf record and will not import it again. You can delete the record(s) and reimport to say update references.

Can anyone here maybe help me with this issue here? CSV-Import Buchung internationales Wertpapier in ein Depot in Euro. I think here might be some people who have had similar issues.

Hello

I thought I had the problem fixed with the latest update, but apparently doesn’t look like it to me.

Please provide an example in .csv (.txt) format, then I can look at it again.

Greetings
Alex

Hi, commented in the actual topic. I only see in the “new release info” this: “Verbesserung: Neue Einstellung: Währung immer anzeigen (= nicht weglassen für die Berichtswährung).”

thanks that you are having a look.