Can’t assign securities account to taxonomy – asset owner reporting

For a while, I’m using a custom Taxonomy I created called “Owner” which has two sub-taxonomies: one for me and one for my wife. This helps me to see who owns what and how our wealth is split (for tax reasons…). This worked well in the past as we didn’t hold the same shares/securities in two different accounts. But this is where it fails: we recently migrated my wife’s robo-advisor account to Interactive Brokers and now we own the same shares in two accounts. And a security can only be attributed/allocated to one taxonomy/owner. It seems I also can’t attribute Securities Accounts to a taxonomy either which would have helped.

Does anyone know a way around this? We always loved this taxonomy and view (in Statement of Assets we could go back in time, etc). Thanks for any help!

See example below. Both our Security Accounts (Interactive Brokers) hold iShares MSCI World shares which now can only be attributed to one taxonomy.

Thank you!

Hey jxxst,

the only way I see around that is to generate two differing securities, e.g. “iShares Core … (me)” and “iShares Core … (boss)”

At the moment I do not know if and where PP distinguished between ISIN and where between the name of a security. You most probably need to play around a bit

I hope it helps

That would be an option indeed I didn’t think about. Unfortunately, when playing around with this option it seems I can’t add instruments twice (with the same ticker name) as PP grey’s out any instruments that I’ve already added in the search results.

Hey jxxst,

I just tried in my PP file. I could add the same security with same WKN and ticker symbol but different name.

If I buy “Varta Kopie” the stocks will not be added to “VARTA AG O.N.” with the same ticker symbol.


Does this help?

Your mistake is using the security search to add the second one. You have to pick the option “empty security” (not sure if it’s the right translation, so I added a screenshot to clarify that). Adding a security twice with the direct search option to add is impossible.

There is only one problem with the solution with 2 securities with the same ticker/ISIN. I think the PDF import is no longer possible because the importer does not know which security to use.

Thanks both! This works… the good thing is that I could just change the past transactions to a different security without entering all price info again. :slightly_smiling_face:

This seems like a good workaround! In the Regions rebalancing view I just have to look at the taxonomy/folder (EM/Developed) level now instead of security level which is also ok.

1 Like