Change account of transaction

Hi

First of all - I love this program and have been using it for some time now. For the first time I have a “problem” I can not solve myself.

As seen on the picture - I have made a handfull of trades for a security. I brought some shares on account 1, transferred them to account 2 and then to account 3. However in my “Trade” overview for that security it is shown that the transaction was made on account 2.

I have tried 200 differens things to correct it, but I can not, similar trades on my other securities are correct. Any ideas?

First – you are not looking at the transactions but at the trades, which are computed from the transactions. Without the transactions, we can’t see exactly what is going on.

Trades look at individual tranches of shares. PP uses FIFO (first in, first out) to determine which shares were affected by a sell or a transfer, if it isn’t the whole position. So it would be possible that the shares you still have from the April 18 buy are, as interpreted by FIFO, not those you think they are (those that were originally in account 1).

Out of curiosity, the locale is Swedish?

I see, my mistake. * “Trades” :slight_smile:

I found out that PP used FIFO and have arranged my transfers accordingly - please see attached file. I have removed everything else including deposit etc., however the result is still the same, there should be no buy orders for account “2” or “5” at all.

The “SELL” orders are GasFees.

I have used the same approach with other Cryptos/Shares aswell, they are all correct, but can not find the mistake here.

Close - I’am Danish :slight_smile:

Forum.xml (271.3 KB)

It may be a bug after all, but I’ll need to look closer.

1 Like

Hi Chirlu

Have you had time to take a look? :slight_smile:

Yes, it’s a bug that happens when buy transactions (but not inbound delivery transactions) are split. I haven’t completely understood yet what exactly is happening, or how to fix it.

Good to know thanks. Glad it isn’t just me. I will wait :slight_smile: