Darstellung Fenster Historische Kurse: Datumsspalte verschwunden


#1

Hallo,

ich habe ein Problem bei der Darstellung bei der Auswahl der Wertpapiere.
Wenn bei der Auswahl Wertpapiere (Standard) ein Papier ausgewählt ist,
erscheint unten das zugehörige Kursdiagramm/Historische Kurse/Umsätze/Ereignisse.

Jetzt habe ich z.B. bei Historische Kurse die Spalte Datum nach links verkleinert und sogar
ausgeblendet. Jetzt kann ich die Spalte aber nicht mehr einblenden. Ist da ein Programmfehler?
Jetzt ist nur noch der Kurs sichtbar.

Viele Grüße
Herbert


Datum fehlt bei historischen Kursen
Keine Datumsspalte in "Historische Kurse" unter "Alle Wertpapiere"
#2

Kann das sein, dass die Spalten jetzt nicht entfernt ist, sondern einfach so schmal ist, dass sie nicht mehr sichtbar ist.

Versuch mal die Spalte über das Zahnrädchen oben rechts zu entfernen und dann wieder hinzuzufügen.

Oder solange mit der Maus “rumfummeln” bis Du sie wieder breiter ziehen kannst :smile:


#3

Hallo,

die vorgeschlagenen Methoden funktionieren leider nicht. Die verschwundenen Spalten im unteren Feld zum Beispiel bei den historischen Kursen lassen sich über ein Suchen und Ziehen mit der Maus nicht wieder einblenden.

Die Einstellungen über das Rad rechts oben beziehen sich doch nur auf das obere Fenster Wertpapiere. Ich habe zwischendurch die xml-Datei unter einem anderen Namen abgespeichert. Das ging für ein paar Tage. Die Ansichten waren in Ordnung. Jetzt ist der Fehler der verschwundenen Spalten wieder da.
Da ist irgendein Bug drin.

Viele Grüße
Herbert


#4

Ich habe das gerade ausprobiert und bei mir funktioniert es. Kannst Du mal einen Screenshot machen?


#5

Hallo zusammen,

jetzt habe ich das Programm auf einem Windows-Rechner ausprobiert.
Dort arbeitet es ordnungsgemäß und man kann über einen doppelstrich-Cursor
schmale oder ausgeblendete Spalten wieder einblenden.

Ursprünglich habe ich die Linux-Version 64 bit unter der Distribution Linux Mint verwendet.
Dort ist nach dem Verkleinern oder dem Wegblenden der Spalte der doppelstrich-Cursor
nicht vorhanden, so dass die Spalte immer verschwunden ist.

Ich hoffe, es hilft zur Aufklärung.

Mit Grüßen
Herbert


#6

Hallo,

ich habe mal ein Screenshot gemacht. Nach dem Ausblenden der Datumsspalte.

Der Fehler ist aber nur bei der Linux-Version.

Viele Grüße

Herbert


#7

Danke @Hoerbi für die Fehler Recherche. Linux…

Da bleibt aktuell nur eine Möglichkeit: das “workspace” Verzeichnis zu löschen. Damit werden die gespeicherten Spaltenbreiten wieder zurückgesetzt. Das findest Du

  • unter Linux: ~/.PortfolioPerformance/workspace
  • unter Mac: ~/Library/Application Support/name.abuchen.portfolio.product/workspace
  • unter Windows: $LOCALAPPDATA$/PortfolioPerformance/workspace wobei $LOCALAPPDATA$ überlicherweise nach C:\Users{username}\AppData\Local zeigt.

#8

Danke für Deine Antwort. Ich habe die Spalte zumindest nicht bewusst verkleinert.

Ich bin jetzt Deinem Link gefolgt und finde dort, daß ich unter Linux das Verzeichnis ~/.PortfolioPerformance/workspace löschen soll.

Ehe ich mir da weiteren Ärger einhandele, frage ich lieber zurück, ob das noch gilt, da der Hinweis schon älter ist.


Datum fehlt bei historischen Kursen
#9

Es kann nicht schaden, eine Sicherheitskopie des Verzeichnisses anzulegen bzw. das Verzeichnis zunächst umzubenennen statt es zu löschen.


#10

Danke. Nach Umbenennen des Verzeichnisses wurde es beim nächsten Start neu erstellt und die Datumsspalte war wieder da.

Allerdings mußte ich dem Programm den Pfad zur xml-Datei zuweisen, da sie sonst nicht gefunden wurde.


#11

Es ist ein paar Tage gut gegangen, aber heute ist die Datumsspalte wieder verschwunden ohne dass ich sie bewusst verkleinert hätte. Alle paar Tage das workspace-Verzeichnis zu löschen kann ja nicht die Lösung sein, zumal anschließend der AlphaVantage Key neu eingestellt und das Speichern der settings neben die Datei auch wieder aktiviert werden muss.


#12

:thinking: Linux?!? Mir ist nicht so ganz klar was da schief geht.

Wenn es das nächste Mal auftritt, könntest du mir die Datei .PortfolioPerformance/workspace/.metadata/.plugins/name.abuchen.portfolio.ui/prf_XXXX.txtzukommen lassen. Und zwar die Datei mit dem neuesten Datum (also vermutlich die mit den Einstellungen für Deine Datei.


#13

Da ich das workspace-Verzeichnis noch nicht “repariert” habe, könnte ich Dir die gewünschte Datei schon jetzt zur Verfügung stellen, wenn ich wüsste, wie ich das anstelle. Ich bin noch relativ neuer Nutzer Deiner Software und finde die entsprechende Funktion nicht.

Übrigens ist es jetzt nicht nur so, daß die Datumsspalte fehlt. Vielmehr fehlt sie bei 2 ETFs und 2 Aktienfonds, wobei bis auf einen ETF auch die angezeigten historischen Kurse falsche Werte zeigen.

P.S. hab vergessen: ja Linux (Debian 9.4)


#14

Ich habe die gewünschte Datei mal an “portfolio dot performance dot help at gmail dot com” geschickt und hoffe, daß das die richtige Adresse ist.


#15

Hier Xubuntu 16.04, der Fehler trat auch schon mal auf. Das Löschen der *.settings beseitigt den Fehler - aber natürlich auch die persönlichen Einstellungen :wink:


#16

Danke @Werner-7 für die Datei!

Laut Deiner Preference Datei sollte die Spalte 80px breit sein - das sollte sichtbar sein…

:thinking:

Verstehe ich das richtig: bei einigen Wertpapiere wird sie angezeigt, bei anderen aber nicht? Das heißt wenn Du durch die Liste Deiner Wertpapiere gehst, ist sie manchmal sichtbar?

Wenn ich @ProgFriese Beitrag richtig lese, reicht auch das Löschen der “.settings” Datei. Dann musst Du zumindest den AlphaVantage Key nicht wieder eintragen.


#17

Danke für Deine Antwort.

Du verstehst mich anscheinend nicht richtig. Die Datumsspalte wird auf keinem (!) meiner Wertpapiere angezeigt. Auf allen Wertpapieren werden historische Kurse angezeigt, die allerdings nur bei einem Wertpapier richtig sind. Bei den anderen 3 Wertpapieren finden sich Werte, die ich nicht nachvollziehen kann.

Ich habe inzwischen das workspace-Verzeichnis wieder neu erstellt, so daß derzeit alles wieder korrekt angezeigt wird. Sollte der Fehler nochmals auftreten melde ich mich wieder.

Nebenbei noch eine Frage: wie kann ich aus Deiner Antwort Teile zitieren? Ich kann da nichts finden.


#18

Einfach den Text markieren. Dann erscheint ein kleines Popup “Zitat”.

Okay, dann habe ich verstanden:

  • Die Datumsspalte verschwindet plötzlich
  • Dann werden bei Wertpapieren falsche historische Kurse angezeigt
  • Es gibt keine Einträge im Fehlerprotokoll
  • Es hilft wenn man die “workspace” Verzeichnis löscht
  • Ein Benutzer berichtet das es auch hilft nur die “settings” Datei zu löschen

Ich bin am Ende meines Lateins. Ich habe momentan keine Idee woran das liegen könnte (Linux…)


#19

Ich habe das gleiche Problem, ebenfalls unter Linux. In meiner Hauptdatei fehlt die Spalte schon seit Monaten und ich hatte auch schon mal alle Verzeichnisse und die Datei direkt abgesucht ohne irgendeine passende Einstellung zu finden.

Interessanterweise scheint es auch abhängig von der angezeigten Datei zu sein. Wenn ich mir beispielsweise die Dax- bzw. Kommer-Beispieldatei neu erstelle, ist die Spalte ordnungsgemäß vorhanden. Diese Beispieldateien hatte ich mir auch mal zwischengespeichert und bei den Zwischengespeicherten geht es mal (Kommer) und mal nicht (Dax). Alles parallel geöffnet im selben Versionsstand. In den einzelnen Dateien finde ich aber wie gesagt keine Einstellung für Spaltenbreite o.ä.

Wenn schon nicht klar ist was das Problem auslöst, dann wäre wenigstens so ein Zahnrädchen für den unteren Bereich sinnvoll. Wenn man dort die Spalte einmal ausblenden müsste (obwohl sie ja schon nicht mehr sichtbar ist) und dann wieder aktivieren müsste, hätte man wenigstens schon was gewonnen.

Ich muss leider drei meiner Wertpapiere manuell einpflegen und wenn ich dann mal schauen will von wann der letzte Eintrag ist, muss ich immer den Umweg über csv exportieren gehen um dann dort auch die Datumsspalte zu sehen. Das ist schon etwas nervig. :frowning:


#20

Danke!
Den Ordner ~/.PortfolioPerformance umzubenennen hat geholfen. Mal sehen wie lange es hält :slight_smile:
Ubuntu 18.04

java Version:
ii openjdk-11-jdk:amd64 10.0.1+10-3ubuntu1 amd64 OpenJDK Development Kit (JDK)
ii openjdk-11-jdk-headless:amd64 10.0.1+10-3ubuntu1 amd64 OpenJDK Development Kit (JDK) (headless)
ii openjdk-11-jre:amd64 10.0.1+10-3ubuntu1 amd64 OpenJDK Java runtime, using Hotspot JIT
ii openjdk-11-jre-headless:amd64 10.0.1+10-3ubuntu1 amd64 OpenJDK Java runtime, using Hotspot JIT (headless)
ii openjdk-8-jre:amd64 8u171-b11-0ubuntu0.18.04.1 amd64 OpenJDK Java runtime, using Hotspot JIT
ii openjdk-8-jre-headless:amd64 8u171-b11-0ubuntu0.18.04.1 amd64 OpenJDK Java runtime, using Hotspot JIT (headless)