Dividendendarstellung

Habe folgendes bei meinen Dividenden gefunden: bei der Dividendenerfassung im Mai 17 zu 532 EUR (Allianz) wird diese in den Berichten- Dividendarstellung mit Faktor 4 hochgerechnet: EUR 2128 EUR.
Habe diese Buchung gelöscht und neu angelegt. Bleibt dabei. Nachgeschaut ins Jahr 2016 passiert dies ebenfalls.
Das passiert auch bei Nestle und noch bei zwei weiteren Aktien. was kann das sein ?

Ist das vllt die Summe aus vier Jahren?
Weiß nicht genau, wo du meinst, aber unter “Bericht/Performance/Wertpapiere” wird in der Spalte “Summe_Div” immer die Summe für den ausgewählten Zeitraum angezeigt.

:thinking: Sehr komisch. Mir ist nicht klar wo der Faktor 4 herkommen soll.

Kannst Du mal Deine Datei posten? (Einfach alle anderen Wertpapiere, Buchungen, und so weiter rauslöschen - nur die Allianz mit dieser einen Buchung drin lassen).

Hallo hier meine Daten:
Es ist mir aufgefallen, dass im Depot c1 befindliche Aktien in der Selektion Dividende, Depot c1 alles richtig ist, wenn ich ein weiteres Depot (beginnend c1_a) die Dividende verdoppelt, verdreifacht etc wird. kommt ein Depot hinzu, welches nicht mit c1… beginnt, dann korrekte Darstellung
1: Umsätze:umsatz
Ich habe bei einer Bank verschiedene Depots, daher der Unterschied von c1, c1_a etc.

Zusatz: bei allen erfassten Dividenden (der vier Depots) gehen diese auf das gleiche Verrechnungskonto

Hallo habe wohl ein Problem mit meinen Depots und den Dividendarstellungen.
WEnn ich unter der Rubrik Dividenen die Einzelnen Depots filter, sind alle Dividenden für das Einzel-Depot richtig erfasst. WEnn ich das GEsamtportfolio auswählen werden einzelne Titel nicht mehr erfasst und somit auch nicht die Dividende. Ich habe schon die Depots umbenannt, abgespeichert und dann das Programm komplett neu gestartet. Keine Abhilfe. was Kann ich tun um das Problem weiter einzugrenzen?

@AndreasB hatte vorgeschlagen:

Hallo Thomas,
habe nun die DAtei bereinigt. Du siehst nun bei der Allianz, Nestle immer unter der Rubrik, “Wertpapiere- Umsätze dass die Jahresdividende doppelt aufgeführt wird. Aber unter der Rubrik " Alle Wertpapiere” Umsätze nur die einmalige Erfassung der jeweiligen Jahresdividende. Bei Nestle etc. das gleiche.
Unter Dividendendarstellung nur das Jahr 2017 wird aber die Jahresdividende doppelt aufgeführt, geschieht aber nur, wenn zwei oder mehr Depots mit ausgewählt werden. Vielen Dank für die Unterstützng

Hallo zusammen,

ja, ich kann den Fehler in der aktuellen Version 0.29.0 bestätigen.

Ich habe drei Depots angelegt und sämtliche Dividenden werden in den Ausgabeberichten als drei einzelne Buchungen dargestellt. Sie werden also 3x so hoch als es korrekt wäre angezeigt.

In den Eingabemasken, wo ich Wertpapiere und Transaktionen/Dividenden erfassen kann, wird richtigerweise nur eine einzelne Dividende angezeigt.

Noch ein Hinweis:
Filtere ich in dem Ausgabebericht nur ein einzelnes Depot, dann wird die Dividende korrekt angezeigt. Das Wertpapier ist komplett nur einem der drei Depots zugeordnet.

Hallo,
die Dividenden werden falsch berechnet wenn eine Aktie in mehreren Depots vorhanden ist.

Beispiel-Datei angehängt: multiple-dividend.xml
multiple-dividend.xml (63,0 KB)
Hier sind drei Depots angelegt mit demselben Wertpapier.
Erträge werden dem jeweiligen Referenzkonto zugebucht.

Siehe angehängter Screenshot 2019-12-17_PP-Erträge-mit-Filter-falsch.png

Im Modul Erträge und Ausgaben:
Ohne Filter (Gesamtportfolio) zeigt die korrekten Werte an.
Wenn man allerdings einen Filter auf test-depot1 und test-depot2 setzt werden die Buchungen falsch angezeigt und verdoppelt. Dies wirkt sich auch auf die Berechnungen und grafischen Darstellungen Monat, Quartal usw. aus.

Aktuelle Version von PP wird verwendet:
Portfolio Performance
Version: 0.43.0 (Dez. 2019)
Platform: win32, x86_64
Java: 11.0.4+11-LTS, Azul Systems, Inc.

Grüße
F

@pgo
Dieses Verhalten ist nicht neu, wenn sich mehrere Depots ein Verrechnungskonto teilen. Dividenden werden dem Verrechnungskonto und nicht dem Depot zugeordnet. Daher kann je nach Filter das Verrechnungskonto mehrfach Anwendung finden.

@Ragas
Hast Du Dir mein Beispiel angeschaut?
Ich durfte kein neues Thema erstellen, sondern sollte hier direkt antworten.

  • Mein Beispiel zeigt separate (nicht geteilte) Verrechnungskonten.
    Test-Depot1 und Test-Depot2 haben unterschiedliche Referenzkonten.
    Nach Anwendung des Filters sind die Angaben schlicht falsch.

  • Aber selbst bei geteilten Verrechnungskonten sollten sich die Dividenden nicht bei Filteranwendung vervielfachen.

So wie ich das Problem umreiße tritt eine falsche Berechnung erst bei identischen Wertpapieren in unterschiedlichen Depots auf.

Meines Erachtens läßt sich das Problem schnell und leicht lösen, indem die Wertpapiere, die mehrfach in verschiedenen Depots angelegt werden sollen, konsequent bei der Stammdatenanlage mit z.B. _1 oder _3 usw. im Anhang zum Wertpapiernamen unterschieden werden. Natürlich müssen diese Werte auch in den Depots und evtl. bei Re-balancing Gruppierungen genauso unterschieden werden.
Bei 30 Watchlisten-Anlagen habe ich das Problem auf diese Weise sofort gelöst bekommen.

Nein nein, @pgo hat zumindest Recht was den Filter betrifft. Die Verrechnungskonten werden abgefragt obwohl nur das Depot gebraucht wird und dann auch noch doppelt und dreifach. Aber was sich nach dem fix nicht ändern wird, Dividenden mehrere Depots auf dem gleichen Verrechnungskonto werden nicht anteilsmäßig berechnet.

Mit Version 0.44.0 sollten zumindest die doppelten Dividendenbuchungen nicht mehr auftreten.

Trotzdem ist noch nicht alles okay: wenn man ein Wertpapier in mehrere Depot hat, aber nur ein Referenzkonto, dann werden alle Dividendenbuchungen herangezogen selbst wenn man sich nur ein Depot anzeigen lässt.

@AndreasB, @Ragas,
Vorab: Es geht mir mit diesem Beitrag nicht darum, Recht zu haben oder zu bekommen sondern als Ergänzung zu meinem Hinweis vom 15.12. (siehe oben) meine kurze, aber bald einjährige Erfahrung beizutragen.
Meine Situation: Ich habe 30 ETF-Watchlisten angelegt, deren Entwicklung ich bei verschiedenen Marktbedingungen beobachten möchte. Dazu habe ich eine Stammdatendatei angelegt sowie 30 Watchlisten, 30 Depots sowie 30 Re-Balancing files im Klassifikation-Bereich. Die Depots wurden angelegt mit der Absicht, unter der Vermögensaustellung die Einstandspreise, Marktwerte sowie für verschiedene Perfomance-Termine die Gesamtsumme der durchschnittl. 6 ETFs in einem Depot geliefert zu bekommen. Die Gesamtsummen u.a. trage ich übrigens manuell in eine Attributspalte oberhalb der Vermögensaufstellung ein, um bereits an dieser Stelle ein Performance Ranking aller Watchlisten zu erhalten.

Da es natürlich vorkommt, dass man in verschiedenen Depots einen ETF mehrfach verwendet bzw. einliefert, habe ich festgestellt, dass für eine richtige Darstellung der Re-Balancing Funktion eine Unterscheidung der ETF-Bezeichung z.B. mit _1 oder _3 als Namensergänzung notwendig ist, da PP sonst bei der Zuweisung des ETFs zu der vorher definierten Kategorie beim Aufbau der Re-Balancing Datei durcheinander kommt, da ja für den einen ETF in verschieden Depots unterschiedliche Bestandszahlen vorliegen. Mit einer klaren Unterscheidung der Bezeichnungen läßt sich eben dann der ETF bei der manuellen Zuweisung exakt auswählen und die Bestandzahl wird richtig dargestellt.
Ich hoffe, ich konnte die Situation nachvollziehbar beschreiben. Wenn ich bei einer solchen WL-Struktur anders vorgehen sollte, wäre ich natürlich für einen Hinweis dankbar.

Not trying to hijack the thread but also seeing strange dividend calculations where PP is making me feel richer than I am :slight_smile:
A screenshot from PP dividend overview from Earnings & Expenses


When I looked at the last month I became suspicous because PP is making me too rich
I exported the data to csv then did a simple sum from Excel which show different results from Feb2019 going forward.

Running PP 0.44, if you need any additional information please let me know. I don’t want to go back to Excel :sweat:

Please help…

In the Earnings & Expenses view, there is a gear wheel at the top right. When you click on the gear, is „use gross value“ checked?

@ProgFriese
I checked and it is not selected:
pp-gross-value

If I do select it, the value goes higher:

It appears that I’ve found the issue with the Excel Calculation!

When you export the data from PP and import it into Excel, you use the „Data to Columns“ option to convert from csv and place all the data into the appropriate cells.

Some of my companies have ", Inc. " in theirs names and because of the way PP exports this data Excel will erase some of their values when converting to excel cells and thereby erasing the data from those companies which in turn made the calculations not line up because some of the data went missing (was hard to find):


So the lesson I learned is to not have any special characters in company names when using PP ( : , ) because if you export the data into excel some data may go missing

1 Like