"Exchange rate of gross value is missing" when importing dividends from CSV

Hi,
Thanks for creating Portfolio Performance. I am still exploring its features, but so far it looks great.

But I have a problem when I try to import historical transactions into my deposit account. Most types of transactions I have tried are successfully imported, but dividends are a problem. I have explained the problem below. Does anybody have a solution for this please?

Here is a brief example of the problem:

I set up a security with currency of GBX . This currency is necessary to allow quotes to be correctly downloaded into my portfolio.

I then created a csv file to test the import of dividend transactions for this security. The contents of my csv file looks like this:
Date,Ticker Symbol,Type,Note,Value
18/08/2020,BARC.L,Dividend,37.50

During the import, the final window of the import shows the dividend transaction as an error, with the text crossed through. When I right-click on the transaction in that window, it shows an error message:
„Exchange rate of gross value is missing (transaction currency GBP and security currency GBX)“.

If I add a Transaction Currency of „GBX“ to the transaction in my csv file and then import it, it gives a different error:
„Transaction currency GBX does not match account currency GBP“

I have tried many combinations of fields and values in the csv file but I cannot get it to work properly. I did notice some similar posts about dividends in the forum but they are slightly different problems and none of them were of help to me.

I can manually add the dividend to my deposit account. I tried that and it worked fine. The problem is that I have many years of historical transactions to import (hundreds of transactions) so it will not be practical to manually add all of them. For curiosity, I looked at the xml file after I manually added the dividend, to see if I could find an easy way to add all my dividends directly to the xml file, but there are some elements in the xml that I cannot understand, eg, the uuid and amount. For reference here is the xml for the dividend after I manually created it:

<account>
  <uuid>05ae13d0-e0d6-436b-97b2-517e2725ea8a</uuid>
  <name>my_deposit_account</name>
  <currencyCode>GBP</currencyCode>
  <isRetired>false</isRetired>
  <transactions>
    <account-transaction>
      <date>2018-03-27T00:00</date>
      <currencyCode>GBP</currencyCode>
      <amount>1022683</amount>
      <shares>0</shares>
      <type>DEPOSIT</type>
    </account-transaction>
    <account-transaction>
      <date>2020-08-18T00:00</date>
      <currencyCode>GBP</currencyCode>
      <amount>3750</amount>
      <security reference="../../../../../securities/security[13]"/>
      <shares>1000000000</shares>
      <units>
        <unit type="GROSS_VALUE">
          <amount currency="GBP" amount="3750"/>
          <forex currency="GBX" amount="375000"/>
          <exchangeRate>0.01</exchangeRate>
        </unit>
      </units>
      <type>DIVIDENDS</type>
    </account-transaction>
  </transactions>
  <attributes>
    <map/>
  </attributes>
</account>

I would appreciate any help with this problem.