Feedback zum Feature Messtool hinsichtlich der Performance

Mit der Version 0.63.0 (Juni 2023) lässt sich ein Messtool nutzen, sobald man die die Einstellung Experimentelle Funktionen aktivieren gesetzt hat. Einfach mal Rechtsklick im Diagrammbereich und dann Abstand messen auswählen, oder direkt den neuen Button neben der Zeitinterval-Auswahl nutzen:
grafik

Danke an dieser Stelle, @AndreasB, für die Anpassungen des Messtools und Übernahme in PP sowie @Nirus für Anpassungen und Feinheiten.

Ein Hinweis an alle, die das Tool verwenden: Es ist bereits ein Performanceproblem bekannt (vermutlich nur unter Windows, deshalb auch noch versteckt als Experimentelle Funktion):

Gebt bitte mal Rückmeldung ob, wann und wie stark das Problem auftritt und welches Betriebssystem ihr verwendet.

4 Likes

Ich sehe da kein großes Performanceproblem bei täglichen Kursdaten zurück bis 01.01.2000, Windows11, i7-1165G7 @ 2.80GHz, RAM 16,0 GB, NVIDIA GeForce MX450. Dass es etwas ruckelt, stört mich persönlich nicht. Man verwendet die Funktion ja nicht ständig. Klasse Erweiterung! Danke und Respekt! :+1:

1 Like

Unter Linux auch kein Problem erkennbar. Auch nicht bei Daten von 1950 bis heute.

1 Like

Danke @FuChuOn & @ProgFriese für eure schnelle Reaktion.

Habt ihr in euren Diagrammen noch weitere Markierungen/Bänder/Durchschnitte angezeigt oder rein den Wertpapier-Chart?
Sobald ich bei mir SMA-Markierungen entferne, merke ich wie die Performance sich verbessert. Aber dennoch wird es nicht so flüssig wie bei @Andreas.
@Andreas, merkst du eine Verschlechterung wenn du noch weitere SMA/EMA/Bänder-Charts aktivierst?

Bollinger Bänder und SMA100 + SMA200 waren aktiv, und die neue prozentuale sekundäre Achse, sonst nichts. Alles bei linearer Skalierung.

Bei mir läuft das messen auch sehr flüssig.

Habt ihr in euren Diagrammen noch weitere Markierungen/Bänder/Durchschnitte angezeigt oder rein den Wertpapier-Chart?

Markierungen: alles außer “Einstandspreis (gleitender Durchschnitt)”
Durchschnitt: EMA 50/200
Einstellungen: Zahlenwerte anzeigen, Prozent-Achse (sekundär)

Bei mir ist es schon ein wenig hakelig, eine Dreiviertelsekunde Updatezeit in /Berichte/Diagramm mit 13+ Werten und seit 1.01.2019

Die Werte in der Box verstehe ich zwar noch nicht ganz, aber ich könnte mir auch Angaben zur Y-Achse vorstellen und daraus resultierenden Renditen oder absoluten Veränderungen.

@Harry_Hirsch: Welches Betriebssystem nutzt du?

Das Format ist: Delta der y-Achse (Tage)|Delta x-Achse|Prozentuales Delta x-Achse
Bsp: Messung über etwa ein Jahr, zwischen den x-Werten 20 und 30.

Könnte man das vielleicht in den Tooltip aufnehmen? Und den Wert der y-Achse runden auf 2 Nachkommastellen (Cent!)?
in deinem Beispiel: delta_x: 366 Tage | delta_y: 10,07 EUR| +50,29%

bei mir funktioniert das Messtool flüssig. Win10. Tolles neues Feature! :slight_smile:

Hallo,

das Betriebssystem ist Windows 10 Pro 64 bit 32GB RAM, Core i7 1,3 GHz

Das Messtool ist eine sehr gute Idee, bei mir ruckelt es allerdings aktuell extrem.
Das wird aber eher an meinem Rechner liegen, letzte Windowsinstallation war Windows 8 vor 6 Jahren. Er wird im Sommer einmal neu aufgesetzt und dann sollte es wieder gehen.