Fehlermeldung: No Java Virtual Machines were found


#1

Hallo,

ich würde sehr gerne die PP Software nutzen aber ich bekomme diese auf meinem rechner mit Win 7 Home Premium 64 Bit eifach nicht zum Laufen.

Wäre klasse, wenn mir jemand helfen könnte.
Danke


#2

Die Meldung lautet: “A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run PortfolioPerformance. No Java virtual machine was found after searching the following locations: …”

Google Translate macht daraus: Zur Ausführung von PortfolioPerformance muss ein Java Runtime Environment (JRE) oder ein Java Development Kit (JDK) zur Verfügung stehen. Es wurde keine virtuelle Java-Maschine gefunden, nachdem die folgenden Orte gesucht wurden: …

Hast Du ein JRE installiert? Hast Du eine 32 Bit oder 64 Bit Version installiert? Hast Du die dazu passende Version von Portfolio Performance heruntergeladen?


#3

Ja ich habe alle Kombinationen durchprobiert. Jeweils eine 32bit und 64Bit installiert.


#4

A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run PortfolioPerformance. No Java Virtual Machines were found after searching the following locations:

Der Fehler scheint nicht ganz unüblich. Ich nutze Eclipse - in diesem Zusammenhang findet man bei Google viel. Eigentlich sollte der Installer vom JRE oder JDK den Pfad anpassen und das JDK verfügbar machen.

Ehrlich gesagt, würde ich das ZIP auch erst mal in einem anderen Ordner auspacken. Du hast das in Deinem “AppData\Local\Temp” Pfad.

Probier doch mal das ganze JRE genau an diesen Pfade zu kopieren. Also von Deinem “Programme\Java\ < dein JRE / JDK >” Verzeichnis nach ~/portfolio/jre so dass der Pfad oben stimmt.


#5

Ich seh hier kein JRE

Bei mir ist jetzt java auf c installiert und entpackt ist pp auf e.

Was genau soll ich jetzt machen?

Wäre klasse, wenn Du mich evtl auf dynasti19978gmx.de anschreiben könntest.
danke


#6

Es sollte möglich sein, das JAVA JRE in das Verzeichnis von PP zu kopieren. Kopiere das von C in das “portfolio” Verzeichnis und nenne das Verzeichnis um in “jre” (Kleinbuchstaben).


#7

Super, das hat schonmal geklappt danke.

Jetzt komme ich aber am Anfang nicht weiter.Wenn ich neben Referenzkonto “hinzufügen” anklicke öffnet sich kein Fenster.
Auch wenn ich das Depot und Referenzkonto manuell ausfülle läösst sich der “weiter” Button nicht auswählen.


#8

Die Beispieldateien kannst Du aber öffnen?

In dem Dialog muss man einen Namen für Depot und Konto eingeben und dann “Hinzufügen” anklicken.

Siehe auch hier:


#9

Ich vermute, dass die Kopie des JRE vermutlich vom automatischen Update-Prozess ausgenommen ist, weshalb ich andere Lösungen vorziehen würde:


#10

Das stimmt natürlich. Ich glaube das “jre” Verzeichnis würde einfach unverändert bleiben.

Die Java Installation direkt in das “portfolio” Verzeichnis zu kopieren ist in der Tat nicht ganz so schön. Aber je nach Computer Kenntnissen rechte einfach umzusetzen… :smile:

Mit Java 9 soll es ja ein noch kleineres, modulares Java geben. Vielleicht baue ich dann auch eine Version die Java direkt mitbringt. Wenn ich mir die Fragen hier zu 32 vs 64 bit anschaue, JRE auf dem Mac, Pfade nicht gefunden, etc., dann könnte es das Leben vielleicht einfacher machen. Die Schwierigkeit ist dann Java über die Online Aktualisierung ebenfalls zu aktualiseren.


#11

Most of the time you can fix this problem by uninstalling the Java runtime and then reinstalling it all over again.

You can also try increasing the amount of system memory allocated to the Java virtual machine by setting an environment variable.

Open the Control Panel
Go to System
Go to Advanced Systems Properties
Then Environment Variables
In System Variables, click Add
New Variable Name: _JAVA_OPTIONS
New Variable Value: -Xmx512M
Click OK

That’s it, your Java program should now be able to execute properly.


#12

Thank You - Thats it!