How to install in Linux

I was given the suggestion of trying this program. But I cannot believe how crazy impossible is to complete such a trivial task as to install a downloaded software on Linux.
I am using Lubuntu. I have downloaded the software. Tried to install it, but hold your horses…
First, I learned somehow that I’ll be needing Java 8. Did the search, installed the program. Great.
Thank I need libwebkitgtk-3.0-0, whatever this might be. Easy? Not so fast. Not available… How to install it? Nothing worked. Followed the suggestions to sudo install a bunch of whatever, still I am not able to get this libwebsutff!
I know it is not a problem of Portfolio Performance. It is the OS, which looks free, but you pay it with your time and nerves.
But wait… Wait… I get a an installation log with the problem! Easy! The file is a 300k of nonsense! How could this be of any help to a non-android (the humanoid robot, not the mobile OS) it is not clear to me. I might try to upload it here… If I understand how to do it.
Thank you for your help!

Use another OS. You are not made for this nonsense.

EDIT: I assume you are using Lubuntu 16.04, where libwebkitgtk-3.0-0 is not available. Furthermore, you don’t need Java 8 but Java 11.

Please show the output of

you@lubuntu:~$ lsb_release -a

you@lubuntu:~$ dpkg -l | grep libwebkit

you@lubuntu:~$ dpkg -l | grep openjdk

Yes. You are right. But (a) I am cheap and (b) it works fine if you all you do is click on Chrome.
Anyway… I read that I need Java 8 here:

kt@prenosnik:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.10
Release: 20.10
Codename: groovy
kt@prenosnik:~$ dpkg -l | grep libwebkit
ii libwebkit2gtk-4.0-37:amd64 2.30.5-0ubuntu0.20.10.1 amd64 Web content engine library for GTK
iU libwebkitgtk-1.0-0:amd64 2.4.11-4 amd64 Web content engine library for GTK+
kt@prenosnik:~$ dpkg -l | grep openjdk
ii openjdk-8-jre-headless:amd64 8u282-b08-0ubuntu1~20.10 amd64 OpenJDK Java runtime, using Hotspot JIT (headless)


In 2016 it was true, now it’s 11.

sudo apt install openjdk-11-jre openjdk-11-jre-headless

I don’t think libwebkitgtk-3 is needed under 20.04, libwebkit2gtk-4 should suffice (I think).

2016, you say… How time flies.
There you go! It works!
Easy. Who needs friends, when you have the internet!