Import of GPX priced divs causes ‘input required for total’ msg


I’ve read the ‘How to use the CSV Import functions for GBX priced securities’ in the PP manual, and the section here on Importing Dividends. I’ve carefully followed the instructions this gives and all initially seems to go well when I attempt to import a csv file containing divs priced in GPX - the field mapping is apparently set up correctly and the wizard doesn’t report any errors.

However, if I then go into any of the dividend records this process creates, beneath the dividend title there’s an error message - as shown in this pic:


The fields I attempted this import on are: date, type, Ticker Symbol, Value, Gross Amount, Currency Gross Amount (GBX), Exchange Rate (0.01), and Cash Account.

I’ve also tried manually entering these divs but get the same error message.

Please, I must be missing something crucial and this is driving me crazy, can anybody help?

Are you trying to import a dividend quoted in GBX into a GBP cash account? If so, did you check the section Reference > File menu > Import in the manual?

However, the Portfolio Performance (PP) software verifies the values within this field (Gross Amount), ensuring that the following calculation holds true: Gross Amount multiplied by the Exchange Rate equals the Value. If the numbers do not correspond, an error message will be displayed, preventing progression to the next step.

Thanks for getting back to me @hug-sch .

Yep, my cash account is in GBP and the issue I’m experiencing only relates to divs I’m trying to import quoted in GPX. The csv file in question contains the gross amount, exchange rate and value fields, and for each row the Gross Amount multiplied by the Exchange Rate (I’ve used 0.01) equals the Value - hence, when I’ve attempted to import this file the import wizard is able to complete the process.

However, if I then view (clicking on edit) any of the dividends its just imported the error message I mentioned earlier is displayed - input required for ‘Total’

Hi Rich,
I’ve tried it with a modified example from the manual and as far as I can see, there seems to be no problem. I’ve included the test.xml (portfolio) and test.csv (dividend).
test.xml (310.2 KB)
test.csv (211 Bytes)

The imported dividend looks as follows.

Date Type Security Name Shares Currency Gross Amount Gross Amount Exchange Rate Cash Account Value Transaction Currency
2024-01-13 Dividend share-1 (GBX) 3 GBX 15 0.01 Deposit-account (GBP) 0.15 GBP

As you can see, I’ve also added the field “Transaction Currency” as the currency of the test-portfolio is quoted in EUR and the deposit account and security is in GBP.

After importing this CSV-file, you can edit the dividend in the app without any error message (in my case)

Big thanks @hug-sch,

I had absolutely no problems with those test files and didn’t get the error message when viewing the dividend.

Somewhat inclined to feel there’s a gremlin in my current setup and that it may make sense to start again with an entirely new XML portfolio file. Bit loath to do that though, as this will entail quite a few securities et al and with the exception of this strange error all did seem good.

Maybe you can try to change test.csv and input the security name of your share and cash account to see if it has something to do with your imported csv-file or with the master data of the security or portfolio.

And/or, you can try to recreate share-1 (GBX) and deposit-account (GBP) in your portfolio and try to import the test.csv.

From both tests, you could probably deduce where the problem lies (csv-file, masterdata of the security, or portfolio settings).

1 Like

Hi again @hug-sch , Many thanks for continuing to help me out with this issue.

I spent quite a lot of time yesterday trying to establish what could possibly cause the error and have come to the conclusion that it seems to be related to my setup only having one cash account, in GBP. I added a second cash account, in Euros (?? could that make any difference) and no longer get the error message :grinning:!!

Strangely though, the ‘sum of dividends’ in the securities report doesn’t reflect any of the dividends I subsequently imported :thinking:

Hi @Rich28
Adding a EUR deposit account shouldn’t make any difference. The issue must be related to some currency setting. Maybe, you can try the following.

  • Make sure that the correct cash account is associated with your security account (see image 1)
  • Delete the cash account column in the csv-file.
  • In step 2 of the import wizard, make sure that the correct cash account and securities account is selected (see image 2). Complete the wizard.
  • Check if the base currency of the portfolio is set to GBP (see second image).

If you’re OK with it, you can always post here a copy of your portfolio with all transactions/securities deleted. I can then try to replicate your error.

That’s a really kind offer @hug-sch - I really would appreciate it if you could take a look at how my portfolio is configured. Here’s the relevant XML file, minus the transactions/securities.

emtypp.xml (138.9 KB)

Hi @Rich28

As far as I can see, the currency settings in your portfolio are OK: GBP as portfolio currency and GIA account, GBX for the Astra Zenica security. Adding a buy transaction for the security and creating dividends (manually and via import) did not produce errors. The dividends are also listed in the sum of dividends column of the security. So, it seems that I can’t reproduce your issues with the empty portfolio. Or am I missing something? I did the following:

  1. Create a buy transaction for the security on 2023-05-13 (see image 1)
  2. Create a dividend manually on date today (see image 2)
  3. Import a dividend on 2024-01-13 with a csv-file (see images 3 & 4). As can be seen, the cash and security account is set in the wizard; not in the CSV-file. Of course, you can also set it in the csv. But don’t forget to check the values in the wizard as I am not sure who takes precedence.
  4. Dividends are listed in the All Transactions view (image 5) and can be edited manually. They also appear in the sum of dividends in the security view (image 6)

I will add the CSV-file. Maybe, you can try to replicate my steps on the empty portfolio from above and on your original file.

Good luck.
test-2.csv (175 Bytes)

Hi @hug-sch,

Thanks for making time to take a look at my portfolio settings and for getting back to me again.

I hold dividend paying securities priced in both GBP and GBX - sorry rather than just providing AZN as a testing holding I should have provided something priced in GBP. Perhaps, the likes of iShares Global Inflation Linked Govt Bond UCITS ETF USD (Acc), which has GILG.L as it symbol.

I’ve done the leg work for you and included that in an amended xml file as attached. But first if you view (edit) the AZN dividend you created earlier the strange error message should be visible. Now go into the amended portfolio file and view the dividend for the iShares Global Inflation Linked Govt Bond test holding - :thinking:, no error message!

emtypp v2.xml (312.8 KB)

Ah, now I see it. It was indeed already visible on the previous portfolio “emtypp.xml”. It seems a bug to me ( @Sn1kk3r5 ?).

  • The error message "Input required for ‘Total’ does not show up, while creating the dividend or importing the dividend via CSV.
  • It becomes visible afterwards; while editing the dividend.
  • The error message only appears when there is a currency conversion between the security and the deposit account.
  • The conversion can be between any currency (GBX > GBP; GBX>EUR; EUR > USD, …)
  • The error message appears only when there is “one” deposit account. Adding a second deposit account makes the error disappear.
  • The error seems to have no other side effects. The dividend sum is visible in the securities view.

@Rich28 Is this correct (especially the last item)?

I look further into it, but for the moment I’m stuck.

Hi @hug-sch,

I hope it isn’t too onerous to resolve.

Not sure whether its connected to ∑div, which in my case had been only aggregating GBP div payments, but weirdly that actually reported the correct figures in respect of both the GBP and GBX div payments in my amended portfolio XML file.

Once again, many thanks for your help.

About the ∑div, are you referring to the fact that the ∑div is expressed in GBP, even if the dividends are paid in GBX? If so, you can change it to GBX (or whatever other currency you want the report to be in) by setting the desired currency in View > Reports > Statement of Assets (top right).

Hi @hug-sch,

There’s quite a few dividend payments, some are in GBP and some in GBX. I’ve been monitoring this for a few days now and ∑div is only picking up on a single GBP dividend payment. Changing the currency to GBX doesn’t make any difference.

I feel this means the final point you made four days ago possibly doesn’t stand (The error seems to have no other side effects. The dividend sum is visible in the securities view).

Can you post a Portfolio xml-file with only a few dividends and only the security in question, in which the error becomes visible? Then we can file a bug report. I can’t reproduce the error.


It transpires I overlooked the need to change the mapping format for the date when I imported the Divs. The default date format (YYYY/MM/DD) for the wizard had been applied, which differs from what’s used here in the UK (DD/MM/YYYY). I re-run the import using the UK date format and is all good now with ∑div.