Import quotes for multiple securities from single CSV file


I’ve read the Manual page in the forum as well as the FAQ but i’m not sure if i have missed anything incase it was not in English.

I am trying to import multiple quotes for multiple securities from a single csv that i have exported from my terminal.

I just can’t find an option to import all from a single action.
The CSV importer in the 2nd step asks the name of security.

If i have many, am i supposed to do it so many times for each symbol ?

In the column mapping, there is only Date, Quote and my symbol column is not there. just ~~~
which doesn’t seem to work.


Dear Charles03,

PP tries to match the internal column naming to the naming in the csv file automatically. in case It does not find a match PP offers you the possibility to map the column naming manually by double clicking on the row underneath the column naming as found in the csv file.

This way I am able to import multiple transactions for multiple securities. However, you need to be within the same data type for the entire file (account transactions or depot transactions)

Without seeing a screenshot or a more detailed description it is hard to judge what went wrong in your case. Where do you read the ~~~? If this comes from the dialog box asking for column matching the — is in a drop down field,which, when pressed offers the PP internal column names.

I hope this helps

1 Like

Thanks for your reply.

From File > Import > CSV Files

„Type of Data“ as
I was using the option „Historical Quotes“

I got a hint from your post and changed it to „Securities“

Now i am able to import historical quotes from multiple securities each with many quotes from a single file.

Thank you PP team, i will definitely try this beautifully reviewed software and hopefully help as i can along the way.