java.lang.NoClassDefFoundError: org/eclipse/swt/accessibility/AccessibleObject

Liebe Community,
folgendes Probelm habe ich. Es werden keine akutelle Kurswerte angezeigt, als auch keine Charts
und auch keine Tortendiagramme etc… Ubuntu 20.04 KDE ist die Version meines Betriebssystem. Fehlermeldung:

Sat Apr 25 13:13:43 CEST 2020
Problems occurred when invoking code from plug-in: "org.eclipse.equinox.app".

java.lang.NoClassDefFoundError: org/eclipse/swt/accessibility/AccessibleObject
	at org.eclipse.equinox.launcher.JNIBridge._takedown_splash(Native Method)
	at org.eclipse.equinox.launcher.JNIBridge.takeDownSplash(JNIBridge.java:173)
	at org.eclipse.equinox.launcher.Main.takeDownSplash(Main.java:2219)
	at org.eclipse.equinox.launcher.Main$SplashHandler.run(Main.java:120)
	at org.eclipse.core.runtime.internal.adaptor.DefaultStartupMonitor.applicationRunning(DefaultStartupMonitor.java:70)
	at org.eclipse.equinox.internal.app.EclipseAppHandle$1.run(EclipseAppHandle.java:271)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:45)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.applicationRunning(EclipseAppHandle.java:261)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1108)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:339)
	at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1062)
	at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)
	at org.eclipse.e4.ui.internal.workbench.swt.E4Application.start(E4Application.java:165)
	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:199)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:391)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:246)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.base/java.lang.reflect.Method.invoke(Method.java:566)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:595)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1501)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1474)
Caused by: java.lang.ClassNotFoundException: org.eclipse.swt.accessibility.AccessibleObject
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
	... 26 more

IMHO muss libwebkitgtk-1.0-0 vorhanden sein.

Was sagt

dpkg -l | grep -i libwebkit

Falls hier nicht „ii libwebkitgtk-1.0-0:amd64“ erscheint, was ergibt

sudo apt-get -s install libwebkitgtk-1.0-0:amd64

-s ist für Simulation, da passiert erstmal nix dramatisches.

EDIT: Sowas ähnliches hatten wir schon mal hier: Kein Scrollbalken bei Währungsauswahl (Linux) falls es das in der Paket verwaltung nicht mehr gibt.

Hallo,
erstmal Danke für die schnelle Antwort. Ich bekomme folgendes angezeigt bei dem dpkg Befehl:

"ThinkPad-X201-Tablet:~$ sudo dpkg -l | grep -i libwebkit
[sudo] password for XXXX: 
ii  libwebkit2gtk-4.0-37:amd64                    2.28.1-1                                    amd64        Web content engine library for GTK"

Wenn ich versuche die Version 1.0-0 : amd64 kommt folgende Fehlermeldung :

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket libwebkitgtk-1.0-0 ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »libwebkitgtk-1.0-0« existiert kein Installationskandidat.

Habe nicht soviel Ahnung von IT. Kann es sein, dass durch die neure Version 4.0-37, ältere Versionen nicht installierbar sind? Wenn ihr Ideen habt, schreibt gerne.
beste Grüße

PS. auf den verwiesen Thread kommt folgende Fehlermeldung ::

1.0.0

Versuch mal folgendes:
alle Anwendungen aus, nur ein Terminal öffnen, darin nacheinander ausführen

cd /tmp
wget http://ftp.ch.debian.org/debian/pool/main/i/icu/libicu57_57.1-6+deb9u3_amd64.deb
wget http://ftp.ch.debian.org/debian/pool/main/w/webkitgtk/libjavascriptcoregtk-1.0-0_2.4.11-3_amd64.deb
wget http://ftp.br.debian.org/debian/pool/main/w/webkitgtk/libwebkitgtk-1.0-0_2.4.11-3_amd64.deb
sudo dpkg -i libicu57_57.1-6+deb9u3_amd64.deb && sudo apt install -f
sudo dpkg -i libjavascriptcoregtk-1.0-0_2.4.11-3_amd64.deb && sudo apt install -f
sudo dpkg -i libwebkitgtk-1.0-0_2.4.11-3_amd64.deb && sudo apt install -f
dpkg -l | egrep -i '(libicu5|libjavascriptcoregtk|libwebkitgtk)'

Nun sollte libwebkitgtk-1.0-0 installiert sein

Das kann aber ganz andere Ursachen haben. Da musst Du am besten ein konkretes Wertpapier angeben (ISIN), mit welchem Symbol (Ticker) hast Du das angegeben, und von wo willst Du die Kurse beziehen.

Hallo, foglendes kommt bei diesem Lösungansatz heraus:

-ThinkPad-X201-Tablet:/tmp$ sudo dpkg -i libwebkitgtk-1.0-0_2.4.11-3_amd64.deb && sudo apt install -f
(Lese Datenbank ... 255104 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von libwebkitgtk-1.0-0_2.4.11-3_amd64.deb ...
Entpacken von libwebkitgtk-1.0-0:amd64 (2.4.11-3) über (2.4.11-3) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libwebkitgtk-1.0-0:amd64:
 libwebkitgtk-1.0-0:amd64 hängt ab von libjpeg62-turbo (>= 1.3.1); aber:
  Paket libjpeg62-turbo ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes libwebkitgtk-1.0-0:amd64 (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für libc-bin (2.31-0ubuntu9) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 libwebkitgtk-1.0-0:amd64

Klappt leider nicht.