macOS: PortfolioManager stürzt ab (EXC_BAD_ACCESS EXC_CORPSE_NOTIFY)

#1

Mein Beitrag ist quasi ungelesen geschlossen worden, eine Nachricht an den Schließer kann ich soweit ich sehe auch nicht schreiben, daher hier noch einmal:
https://forum.portfolio-performance.info/t/portfolioperformance-unter-mac-os-stuerzt-beim-start-direkt-ab/5049/3

PortfolioPerformance stürzt beim Start unmittelbar ab. Es lief bereits gut, um dann plötzlich dieses Verhalten zu zeigen. Neu herunterladen hilft nicht. Die Meldung “… kann nicht geöffnet werden” ist wie bereis im Ursprungsbeitrag geschrieben explizit nicht das Problem, denn die beruht auf dem mac OS Sicherheitssystem und lässt sich entfernen. Ich zeige sie in meinem Screenshot nur der Vollständigkeit halber.

#2

:thinking: Nicht ganz klar was da passiert… Der Crash tritt auf bevor irgendwelcher Java Code ausgeführt wird.

Ich habe keine wirkliche Idee - ich würde folgende Punkte mal ausprobieren:

Erstens der Prozess ist “translocated” - das liegt daran, dass Du PP nicht aus dem normalen Anwendung-Verzeichnis startest. Probier mal es nach Anwendungen zu verschieben und dann zu starten:

Notes:                 Translocated Process

Zweitens probier doch mal ob Du PP von Terminal aus starten kannst - auf Stackoverflow wird ein ähnlicher Fehler zu Eclipse gemeldet.

Im Terminal:

/Applications/PortfolioPerformance.app/Contents/MacOS/PortfolioPerformance

Drittens könntest Du versuchen das Workspace Verzeichnis löschen (wenn es denn schon existiert). Diese ähnliche Problemmeldungen Problemmeldungen könnte man so interpretieren.

Viertens könntest Du versuchen ohne das eingepackte Java JRE zu starten. Dazu entfernst Du aus dem PortfolioPerformance.ini die beiden Zeilen zur VM (-vm und die nächste Zeile). Du brauchst dann eine Java JRE auf Deinem Rechner (zum Beispiel von Oracle).

Sorry, das sind alles nur Versuche - lass mich wissen ob irgendwas davon geholfen hat.

#3

Dankeschön! Geholfen hat nichts:

  1. ins Programme Verzeichnis verschieben hat nichts geändert.
  2. Vom Terminal aus starten hat nichts geändert.
  3. Workspace Verzeichnis löschen hat nur wieder die “… kann nicht geöffnet werden” Meldung hervorgeholt.
  4. Die beiden vm-Zeilen aus der PortfolioPerformance.ini entfernen hat nichts geändert.

Danke natürlich trotzdem für die Mühe.