Nach Update keine Vermögensaufstellung mehr


#1

Ich habe da ein komisches Problem. Auf meinem PC hat das 26.3 update ohne weiteres geklappt. Auf meinem Laptop wird jedoch seitdem nicht mehr die Vermoegensaufstellung angezeigt, sondern eine ellenlange java code Liste. Beide sind auf Sprach deutsch eingestellt.

“java.lang.reflect.InvocationTargetException”

Alles andere wird noch korrekt dargestellt (Vermoegensdiagramm, Bestaende etc…). Die xml scheint es nicht zu sein, denn wenn ich die gleiche Datei auf dem PC oeffne, geht alles.

Was koennte das sein? Anbei das Logfile.

Gruss
Jochen

Fehler.txt (5,9 KB)


#2

Hast Du schon probiert die GUI zurückzusetzen (über das Hilfe-Menü)?


#3

Hab ich, ohne Erfolg. Danach auch nochmal neu runtergeladen und neu installiert. Fehler bleibt.


#4

Habe leider immer noch dieses Problem. Kann man das Problem mit der Fehlermeldung identifizieren?


#5

Mmmhh. :thinking: Das ist auf jeden Fall ein Bug. Etwas komisch ist, dass der “nur” auf dem Laptop auftritt aber nicht auf dem PC.

Das Problem ist folgendes: für eine Buchung erwartet PP eine Wechselkurs, findet den aber nicht (darum die NullPointerException). Der Fehler tritt erst seit der aktuellen Version auf, weil PP jetzt nicht den historischen Wechselkurs zur Berechnung des FIFO Einstandspreises nimmt, sondern den Wechselkurs der eigentlichen Buchung.

Es muss sich um ein Wertpapier handeln, dass in einer anderen Währung notiert ist als das Referenzkonto. Ich weiß nicht wie viele Du davon hast, aber vermutlich reicht es, wenn Du diese Buchungen noch mal editierst.

Mir ist allerdings nicht ganz klar wie dieser Zustand entstehen konnte. Eigentlich darf man eine Buchung von einem USD Wertpapier auf einem EUR Konto nicht ohne Wechselkurs erfassen. Anfang Januar gab es mal einen Bug in PP bei dem Eingaben in den Buchungsdialog nicht richtig validiert wurden. Das könnte erklären warum falsche Daten “reingekommen” sind. Wenn Du die Buchung gefunden hast, sag doch mal von wann die ist.


#6

Interessant ist folgendes: jetzt wird auf einmal die Vermaufstellung wieder angezeigt, es kommt aber ein Pop-up anstelle der Fehlermeldungen direkt in der Vermaufstellung.

ich weiss jetzt aber auch nicht wo ich da anfangen soll. komisch ist ja dass die GLEICHE pp-datei auf dem PC und auf meinem Firmenlaptop ohne Probleme oeffnet, nur auf meinem privaten Laptop nicht.

gibt es irgendwelche registry oder andere configs die mann loeschen koennte? den PP Ordner habe ich mehrach geloescht und neu runtergleaden. Es findet aber ja in dem Sinne keine Systeminstallation statt.


#7

Das ist in der Tat komisch. NullPointerException sind eigentlich immer Bug. Eine Buchung ist “kaputt” - oder anders als von PP erwartet. Es muss eine mit einer Fremdwährung sein. Einfach mal (an einer Kopie) die Buchungen der Reihe nach löschen? Du kannst mir auch gerne die Datei schicken und schaue mal rein.


#8

Ich habe jetzt mal nacheinander alle einzelnen Portfolios innerhalb der Datei geloescht und rausgefunden, dass eine einzelne Wertpapiereinlieferung vom Aug-16 das Problem ist! Was ein K®amp. Merkwuerdig ist doch wirklich, dass sie bisher keine Probleme bereitet hat, und jetzt auch nur auf einem bestimmten Laptop.

Ich schicke dir mal einen Datei nur mit diesem Eintrag.


#9

Vielen Dank für die Datei!!! Ich habe jetzt den Bug gefunden.

Das Problem ist, wenn man in der Vermögensaufstellung eine Gruppierung wählt, in der das Wertpapier auf verschiedene Klassifikationen aufgeteilt wird. In Deinem Beispiel ist das Wertpapier teilweise dem “Barvermögen”, “Eigenkapital” und “Fremdkapital” zugeordnet. Nur dann tritt der Fehler auf (und das auch nur seit der letzten Version weil ich seit dem den Wechselkurs der Buchung und nicht den historischen Wechselkurs nehme).

Das könnte auch erklären warum der Fehler nur auf einem Rechner auftritt. Auf dem anderen Rechner gruppierst Du die Vermögensaufstellung vermutlich anders - z.B. nach Währung oder Asset Allocation.

Das Problem werde ich jetzt mal beheben. Kommt mit der nächsten Version.