No % change and amount change shown using Yahoo Finance

Hi, I would like to ask you guys about a problem using Yahoo Finance as quote provider.
There is always no data showing in the % change and amount change as below when the market is close (there are numbers showing when the market is open):
Screenshot 2021-02-27 192622

Using Finnhub is fine but I can’t find some of the index or ticker and I don’t want to use too much of the 60 free API calls of Finnhub, therefore I used Yahoo Finance. But would really like to solve this problem. Thank you in advance.

HI qlp19, could you shortly state in which table exactly you encounter that problem? I also have some index symbols I track and I was not able to reproduce that.

1 Like

Thank you for your response.

I encounter this problem in the “All Securities” table or should I call it the watchlist?
pic below:

Before I make the screenshot I also changed the quote provider of TSM to Yahoo Finance from Finnhub (I also pressed “keep historical quote” in the pop-up). After that the % change and amount change all turn to 0.

As for other tickers with numbers in the % and amount change, they are all using Finnhub as quote provider.

Once again, thank you for your response.

You are very welcome, that’s what forums are made for :slight_smile: As english is not my native tongue, let me know if something is not understandable.

I am using various index just like you, in my case (see screenshot) it works perfectly with Yahoo Finance, so I suppose we just have to figure out what adjustments you need to make in order for it to work correctly.

Let’s take DJI as trial case: I use Yahoo Finance to deliver historical and current data, stock exchange is set to ^DJI (^DJI) and current is set to “as historical data”. That’s pretty standard, so I do not see any easy reason for it not workin in our case. Will put some screenshots below (sorry field / column names in German, let me know if you cannot match them).

Some ideas of what could be wrong: calendar used not standard, Yahoo set to adjusted close instead of normal, no selection made for historical data, some coupling to other settings that confuse PP, e.g. left over from coupling to different data provider?.

Regards, Christian

1 Like

Thank you for the detailed response. I have deleted Dow Jones and added it back using your settings. But still got the same problem. Below is my screenshot:
1
2

4

Seems not to be an easy one…I know, if it would be easy, you wouldn’t have asked :slight_smile:

You’re settings are absolutely like mine, so what else could be different?

I am using PP 0.50.4 on Mac Big Sur 11.2.2, so you might check, whether all updates have worked correctly.

Secondly I have displayed the date columns on my chart and I see, that dates for “latest” and “last historical” are different in your screenshot and same in mine. See below.

Would it make sense that your PP does not calculate the data, because some date is missing or something? Have you tried triggering the call of quotes manually? Other than that no further ideas, maybe somebody else has more ideas.

Bildschirmfoto 2021-02-28 um 16.19.51

1 Like

Yes. Not an easy one. :sweat:
I am using 0.50.4 (the latest one) on Windows 10 Home.
Not sure if related. When I create this profile I chose the base currency as USD. I am from Hong Kong.
I have tried the below but still no data shown:-

Here is the data I copied from “Debug: show server response”:-

{“chart”:{“result”:[{“meta”:{“currency”:“USD”,“symbol”:"^DJI",“exchangeName”:“DJI”,“instrumentType”:“INDEX”,“firstTradeDate”:475857000,“regularMarketTime”:1614377091,“gmtoffset”:-18000,“timezone”:“EST”,“exchangeTimezoneName”:“America/New_York”,“regularMarketPrice”:30932.37,“chartPreviousClose”:30937.04,“priceHint”:2,“currentTradingPeriod”:{“pre”:{“timezone”:“EST”,“start”:1614330000,“end”:1614349800,“gmtoffset”:-18000},“regular”:{“timezone”:“EST”,“start”:1614349800,“end”:1614373200,“gmtoffset”:-18000},“post”:{“timezone”:“EST”,“start”:1614373200,“end”:1614387600,“gmtoffset”:-18000}},“dataGranularity”:“1d”,“range”:“1mo”,“validRanges”:[“1d”,“5d”,“1mo”,“3mo”,“6mo”,“1y”,“2y”,“5y”,“10y”,“ytd”,“max”]},“timestamp”:[1611757800,1611844200,1611930600,1612189800,1612276200,1612362600,1612449000,1612535400,1612794600,1612881000,1612967400,1613053800,1613140200,1613485800,1613572200,1613658600,1613745000,1614004200,1614090600,1614177000,1614263400,1614349800],“indicators”:{“quote”:[{“open”:[30893.779296875,30377.189453125,30553.91015625,30054.73046875,30276.880859375,30689.650390625,30737.779296875,31093.810546875,31191.19921875,31359.880859375,31428.01953125,31466.490234375,31420.80078125,31472.080078125,31485.609375,31558.599609375,31504.130859375,31381.119140625,31501.890625,31499.75,31955.939453125,31401.2890625],“close”:[30303.169921875,30603.359375,29982.619140625,30211.91015625,30687.48046875,30723.599609375,31055.859375,31148.240234375,31385.759765625,31375.830078125,31437.80078125,31430.69921875,31458.400390625,31522.75,31613.01953125,31493.33984375,31494.3203125,31521.689453125,31537.349609375,31961.859375,31402.009765625,30932.369140625],“low”:[30206.91015625,30377.189453125,29856.30078125,30014.970703125,30276.880859375,30521.310546875,30737.779296875,31083.220703125,31191.19921875,31245.859375,31221.3203125,31244.359375,31347.80078125,31443.48046875,31338.759765625,31285.3203125,31469.33984375,31286.5703125,31158.759765625,31421.2890625,31293.3203125,30911.369140625],“volume”:[5664700,4651400,5363200,3470600,3331600,3055900,3383300,2935500,3222500,3082100,3264500,2803200,2630900,3292100,3435100,3259900,3530700,3872100,4604100,4101500,4541100,5322500],“high”:[30893.779296875,30951.41015625,30553.91015625,30335.91015625,30840.5390625,30793.41015625,31065.9609375,31252.1796875,31386.099609375,31439.470703125,31511.439453125,31543.8203125,31475.310546875,31608.630859375,31643.69921875,31558.599609375,31647.529296875,31653.48046875,31653.380859375,32009.640625,31984.76953125,31450.890625]}],“adjclose”:[{“adjclose”:[30303.169921875,30603.359375,29982.619140625,30211.91015625,30687.48046875,30723.599609375,31055.859375,31148.240234375,31385.759765625,31375.830078125,31437.80078125,31430.69921875,31458.400390625,31522.75,31613.01953125,31493.33984375,31494.3203125,31521.689453125,31537.349609375,31961.859375,31402.009765625,30932.369140625]}]}}],“error”:null}}

Thank you.

Thank you for pointing out that the “Latest (Date )” and the “Last historical (Date)” is different (Feb 27 and Feb 26) in mine while they are the same in yours (Both Feb 26).

After I deleted the latest price, the data is showing correctly, as below. However, once I do a global quote update, the dates were again different (Feb 27 and Feb 26) and the data is missing again. So there must be some problem related to the inclusion of an additional day:-


From HongKong, that’s cool, I have been there in 1996, fascinating city! Cannot believe it, that a quarter of a century now, was during my university times.

I am pretty sure that the calculation is not working as the two dates are different, but I do not have a clue why. On other quotes above, where “latest” and “last historic” are the same it also works on your PP. I would not see any problem with USD and the dates, for sure the date border is in the pacific ocean between the US and HK, but that would surprise me.

@AndreasB Could you have a look at this one and maybe give a hint on the problem, all necessary data is in above threat. Thank you.

1 Like

Please try changing the calendar for US-Indices to NY
Bildschirmfoto_2021-02-28_18-08-02

The problem is that the ticker symbol is “escaped” and “santize” and then not work.
Here are the URL’s for the diffrend extracts in the API-Query for Yahoo:

Ticker-Symbol: DJI and Ticker-Symbol: ^DJI

C ya
Alex

Thank you for your repsonse.
I have tried this but still not working.

I have tried using “DJI” as the symbol and it did seem to be working. But I remember thinking “DJI” and “^DJI” seem to be showing slightly different numbers and after searching in Yahoo I believe “^DJI” is the one I would want to track.

However, this is not working on my other indexes, i.e. “^GSPC” (S&P500) and “^IXIC” (NASDAQ Composite). After removing the “escape” sign, nothing is showing in the historical and current quote.

Yahoo Finance is also not working on all my other symbols such as “TSM” like I mentioned in previous post. Only after I delete the latest price using the right-click menu would there be numbers showing. But as long as I do a global quote update, they all show “0” again.

I believe the problem is caused by the inclusion of an additional day. That’s why when I delete the latest price, the numbers are showing correctly.

Thank you.

Have you tried a combination of ^DJI and the NY calendar?

Yes. But it’s not working.

Even tried changing the default calendar in Help → Preferences to NY Calendar. Still not working. :cry:

Would really appreciate it if someone can look into this matter.
I even tried deleting the software and using a newly extracted one
and then creating a new profile to use Yahoo Finance as quote provider.
But there is always the inclusion of an additional day when the market is close
so the % change and the amount % is always 0.

Thank you.

Update:
The only temporary solution I found is this…
Every time before I open the software, I go to the settings in my Microsoft Windows and change the date to 1 day before. Then I open the software and the “Latest (Date)” would match with the “Last historical (Date)” to be the same date and all the quotes and % changes would show correctly.

However, if I keep the software opened and change back the date in my Windows settings and do a global quotes update. Then the dates of “Latest (date)” would again become 1 day more than “Last historical (Date)” and mess up the % changes data (all become “0”). I can only do global quotes update and not mess up the data when the date in my Windows is set to be 1 day before.

Therefore, I am sure the problem or bug I encounter has something to do with the way the software calling the date in the local machine, or different timezone or calendar.

Although it’s quite inconvenient having to switch the date on my computer back and forth, I guess it did temporarily solve my problem. Really appreciate if the developers of this wonderful software could look into this issue. I am sure there are quite a number of people having the same problem. As least I am having this problem in both of my home and work computer. So there’s that.

Thank you.