PP wird immer langsamer

Ich hab mal ein bischen herumprobiert (Win7 64, 16GB Ram). Diese Anpassungen haben das Laden des Diagramms tatsächlich deutlich beschleunigt:

-Xms4096m
-Xmx12288m

Der Rest wurde dabei aber nicht merklich beschleunigt.

Die Einstellung Xss512k würd ich aber nicht weiterempfehlen, die hat das Laden der Berechnung sogar verlängert

6 Sekunden wäre ein Traum, also bei mir dauert es beim ersten Start der Vermögensübersicht zwischen 3-10 “MINUTEN”!

:frowning:

Das ist aber sehr untypisch! Was für ein System, wie groß ist deine Datei, verschlüsselt?

Müsste so 2.000 KB sein und ist verschlüsselt auf einem Windows system.

Naja verschlüsselt wird sicherlich schon Mal etwas länger dauern. Aber bei 2 MB sollte das meiner Meinung nach nicht im zweistelligen Minutenbereich liegen. Mit was für ein System meinte ich allerdings wie groß dein Prozessor, Arbeitsspeicher ist. Was steht denn in der oben genannten Datei bei dir, hast du das Mal angepasst?

gute frage. laptop ist schon was älter hat glaub 8 GB arbeitsspeicher und wahrscheinlich so ein 1,9 Prozessor oder so.

die datei hatte ich mal angepasst, da hat sich aber nichts getan.

ist auch nur beim ersten öffnen so. wenn ich dann im laufenden pogramm hin und her drücke kommt es aber bei der vermögensaufstellung trotzdem zu langen wartezeiten. würde dann sagen dann dauert es so 30 sekunden. vielleicht max. ne minute. manchmal auch schneller.

Naja vom Arbeitsspeicher sollte das schon reichen. Der Prozessor wird wahrscheinlich beim entschlüsseln das Nadelöhr sein. Du könntest aber trotzdem Mal die Werte aus dem Post oben konfigurieren. Ich vermute eine Verbesserung wird es bringen :slight_smile:

hab ich ja schon mal wie geschrieben schon gemacht. hat sich aber nichts verändert.

Ach das meintest du mit der Datei, sorry da stand ich auf dem Schlauch. Also steht da bei dir folgendes drin?

-Xms2048m
-Xmx6144m
-Xss320k

Richtig? Dann würde es wahrscheinlich nur helfen schnellere Hardware zu nutzen oder eine nicht verschlüsselte Datei (falls nicht wirklich notwendig). Scheint aber kein generelles Problem zu sein, mein PP läuft bei größerer Datei deutlich schneller

Hallo zusammen,
habe seid dem letzten Update das Gefühl, dass PP deutlich länger braucht zum Öffnen des Programms und Anzeigen der Dashboards. Die Einstellungen in der INI sind unverändert, das habe ich eben nochmal kontrolliert. Hat das noch jemand beobachtet, gab es eine Änderung, die das verursachen könnte?

Ich habe keinen Unterschied bemerkt. Nur beim ersten Start nach Update dauert es wie immer länger.

Ja das ist selbstverständlich. Vielleicht irre ich mich auch, deshalb dachte ich ich Frage Mal. Wenn es niemandem anderen genauso geht spiele ich die Tage Mal mit einem Backup und einer älteren Version und vergleiche es.

könnte man diese Tuningeinstellungen nicht standardmäßig in PP einarbeiten, um das Friemeln am Code für unbedarfte Anwender zu minimieren?

Das mit Version 0.58 eingeführte binäre Dateiformat hat bei mir einen deutlich größeren Geschwindigkeitszuwachs gebracht als die o.g. Konfiguration.

2 Likes

danke das Binary Format ist wirklich deutlich schneller.

Wie experimentell ist das Binary Format noch? Bestehen Risiken des Datenverlustes?

Ich selber nutze es seit ca. 6 Monaten (genau um den Code “abhängen” zu lassen). Plus: es werden weiterhin die Backup Dateien geschrieben. Also ich bin ziemlich sicher. In ein, zwei Release werde ich auch das “experimentell” entfernen

3 Likes