Programm startet mit Java 6 nicht mehr


#1

Hallo,

ich musst mein Java von version 8 auf 6 “downgraden” da ein Programm was ich für die Arbeit brauche nicht funktioniert wen eine neuere Java Version als 6 installiert ist.
Seit dem sagt PP mir beim Starten “Ein Fehler ist aufgetretten. Informationen hierzu ernthält die Protokolldatei C:…”

Ich kann leider nicht den Kommpletten Text aus der Datei hier rein schreiben weil es zu viele Zeichen sind und Hochladen kann ich die Datei auch nciht deswegen hier nur der Anfang der in der Datei steht

java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=de_DE
Command-line arguments: -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.equinox.common 4 0 2018-03-20 17:00:50.216
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.common [111]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1600)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.core.contenttype 4 0 2018-03-20 17:00:50.241
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.core.contenttype [36]
Unresolved requirement: Require-Bundle: org.eclipse.equinox.preferences; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.preferences; bundle-version=“3.6.1.v20160815-1406”; singleton:=“true”
org.eclipse.equinox.preferences [152]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Require-Bundle: org.eclipse.equinox.registry; bundle-version="[3.2.0,4.0.0)"; resolution:=“optional”
-> Bundle-SymbolicName: org.eclipse.equinox.registry; bundle-version=“3.6.100.v20160223-2218”; singleton:=“true”
org.eclipse.equinox.registry [153]
Unresolved requirement: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.7.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.common; bundle-version=“3.8.0.v20160509-1230”; singleton:=“true”
org.eclipse.equinox.common [111]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Import-Package: org.eclipse.core.runtime.jobs; resolution:=“optional”
-> Export-Package: org.eclipse.core.runtime.jobs; bundle-version=“3.8.0.v20160509-0411”; bundle-symbolic-name=“org.eclipse.core.jobs”; version=“0.0.0”
org.eclipse.core.jobs [48]
Unresolved requirement: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.8.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.common; bundle-version=“3.8.0.v20160509-1230”; singleton:=“true”
Unresolved requirement: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.common; bundle-version=“3.8.0.v20160509-1230”; singleton:=“true”
Unresolved requirement: Require-Bundle: org.eclipse.equinox.registry; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.registry; bundle-version=“3.6.100.v20160223-2218”; singleton:=“true”

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.core.databinding 4 0 2018-03-20 17:00:50.245
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.core.databinding [38]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.8))"
Unresolved requirement: Require-Bundle: org.eclipse.core.databinding.property; bundle-version="[1.3.0,2.0.0)"
-> Bundle-SymbolicName: org.eclipse.core.databinding.property; bundle-version=“1.6.0.v20160427-0852”
org.eclipse.core.databinding.property [44]
Unresolved requirement: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.common; bundle-version=“3.8.0.v20160509-1230”; singleton:=“true”
org.eclipse.equinox.common [111]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=1.7))"
Unresolved requirement: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.common; bundle-version=“3.8.0.v20160509-1230”; singleton:=“true”
Unresolved requirement: Require-Bundle: org.eclipse.core.databinding.observable; bundle-version="[1.3.0,2.0.0)"; visibility:=“reexport”
-> Bundle-SymbolicName: org.eclipse.core.databinding.observable; bundle-version=“1.6.0.v20160511-1747”
org.eclipse.core.databinding.observable [42]
Unresolved requirement: Require-Bundle: org.eclipse.equinox.common; bundle-version="[3.2.0,4.0.0)"
-> Bundle-SymbolicName: org.eclipse.equinox.common; bundle-version=“3.8.0.v20160509-1230”; singleton:=“true”

at org.eclipse.osgi.container.Module.start(Module.java:444)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1620)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1599)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1571)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1514)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

Ich habe schon versucht die 32 Bit Version zu downloaden die klappt auch nicht.
Läuft PP nicht mit Java 6 oder gibts da einen Trick.

Mit freundlichen Grüßen
Alex


#2

Java 6 hilft hier bei PP nicht weiter.

Da du eigentlich 2 verschiedene Versionen parallel bräuchtest, vielleicht hilft ja folgender Vorschlag:

Gruß
Marco


Problem beim ersten Start (Windows)