Roll back latest PP upgrade

Version 0.56.3 / 9 January 2022 installed on Win10 with autoupdate has a date bug which messes up recent reporting. I downloaded the previous GitHub version.

What’s the best way of:

  1. replacing the latest update, preferably retaining settings
  2. replacing all quotes (ie delete and redownload)

Uh, I don’t understand what the bug is supposed to be nor what your comments on that issue have to do with the original report …

This post is about reinstalling an older version.

As an aside, I don’t understand the bug either but I think it’s the same issue. Reporting is basically screwed and I reported the data and price inconsistencies. Why would new PP version be reporting weekend prices and missing weekdays? (Unfortunately, I can’t reproduce the original data from straight after the upgrade which was really screwy.) Testing could be affected by time of day.

About 1:
Delete your installation, download and unzip the old version.
Keep in mind, that new versions sometimes update the XML format with new properties - then the old version cannot load the new file. But for the January version, there was no change.

About 2:
Delete and re-download is the only option

(I’ll look at the other bug report as well, but I am not aware of any change in that code in the January 2022 version of PP)

1 Like

I understand data file can just be opened in this instance. Reloading data from CSV file is a bit tricky:

  1. Download All transactions and All Securities enabling all required fields.
  2. ??? File Import - can’t import anything
  3. Create dummy book - File, New, Currency, Broker, Bank
  4. File, Import, CSV files, All_transactions.csv, Type of Data: Portfolio Transactions (or Account Transactions), some field names don’t match and it only imports to dummy accounts instead of accounts in CSV file.
  5. I’ll come back to this…

I’d expect exporting All transactions (the only account export) would be recreated by importing [All] Account transactions, creating both Deposit and Securities Accounts during the import.

GNU sed on Win10
sed -i.bak '/\^<price t=/d' hack.xml