Unable to import historical data tables from Investing.com anymore

As indicated on the title, the program is not able to scrape data from the historical price tables from Investing.com anymore.

The URL in question is for XRP MYR Luno data.

I noticed that the last drawn data was from 16-8-2022. When I tried to load the table, it’s blank, as shown here:
Screenshot 2022-08-24 074046

I tried to replicate the issue with a popular stock, AAPL, with the same results :
Screenshot 2022-08-24 074259

Is there a way to circumvent this issue? Or is it better to report this issue on the project github?

This will not solve the problem. INVESTING.COM has updated their website to avoid content grabbing.

1 Like

I see. Then what is the best course of action for now? Is it possible to circumvent this, or do we have to look for an alternative site to draw data from? As far as I know, not many sites are as comprehensive as investing.com

As far as I see for the moment it’s only an issue with the date format (M/d/yyyy), I proposed an addition in order to recognize it correctly:

3 Likes

Ups, sorry for my first wrong Informationen. When I’ve earlier checked the HTML code I run into the Cloudflare protection which give me the wrong feedback and vanished some code.

Thanks, hopefully we can see it merged, and the issue fixed with the next update.

hi, will this be addressed in the next update?

Most likely, yes.

1 Like

no success here either on scraping data from investing.com

Yep, you have to wait for the next update. That comes, then it comes. There is no hard schedule for it.

Or you could use the German investing.com site for grabbing in the meantime

1 Like