Unequal update of share values

Firstly thank you for a very useful investment tool!
I have noticed recently that the “the quoted price” is out of date where as for another share it has the correct date and value. If i hover over the line the bubble shows as it should lastest price and date but it seems locked at a previous data point, if i go to another its correct. I have checked the “security master data” entry and there its correctly finding the data points but seems not to be using them.
Any ideas? I have done a “debug reset” but no change.


did you checked the configuration for the prices? Can you share a Screenshot of the actual and historical tab?

Here are the screen shots, one item I looked at this morning has been updated so seems something variable is happening

Many thanks

the master data tab

now only 4 out of 19 stocks are have updated prices

Hello again
So does anybody have any ideas? I am running ppi on linux machine, the historical data is received from Yahoo and can be seen in master, but does not show after only that of November 3 depending the stock.

Hello, After the recent update today the problem is still there! i tried to change the time zones but makes no difference, some are many days incorrect but the table of dates and historical values are all correct.

Still no cure for this problem, today only 2 out of 22 values in “change on previous day” column are using the correct data of value and date to calculate change, this seems to be random another day its different shares and dates / values. If I check the historical data it is up to date.
I someone working on this?

As far as I know, the dialog “Security - Historical Quotes” shows a live view of the Yahoo Data Website and not the daily imported values in Portfolio Performance. Therefore, the correct values in this dialog mean only, that the configuration is okay.

Maybe there is a problem with the daily update of all security quotes which is done automatically in a background process. Are there any errors in the log file, related to the quote update? Timeouts? Parsing errors, …

And what happens when you select the security with the old data and you choose “Online” - “Update quotes (selected security)” from the menu?

1 Like

Hello tquelle
In the past I tried “update quotes online” before and it made no difference, today I tried and it does not bring up any special errors,
I opened it today after doing a debug reset (again) and checked the “security performance” % change tab and today every one is up to date!! I have uploaded the error report in this response.

I am hoping it stays this way, I can imagine other users have had the same problems.

Thank you for your interest!

pp-error-2022-02-26.log (594.6 KB)

Hallo David,

there is no obvious problem in the log. But for some securities it seams that “Alpha Vantage” is configured as provider for the quotes (“Alpha Vantage API key is missing. Configure in preferences.”). I don’t think that this is the source of the problem, but maybe you can fix this.

And in the “All Securities” you can activate the column for “Date of last quote”. There you can monitor, if (and how fast) the daily update works for all securities. Maybe this gives us a hint to the problem.


Hi Tom,
The function “Date of last quote” is good, i have added it and it showing the dates ok
I will monitor this column and see how goes