Version 0.32 unter macOS: The operation couldn’t be completed. (OSStatus error 99999.)


#1

Hallo,

Seit dem Update auf 0.32 kann ich PortfolioPerformance unter macOS nicht mehr starten. Die letzte Version (0.31.x) lief problemlos.

Ich bekomme folgende Fehlermeldung:
“The operation couldn’t be completed. (OSStatus error 99999.)”

Schöne Grüße,
Martin


#2

Hallo Martin,

wenn ich http://hints.macworld.com/article.php?story=20130803041717457 als Windows Anwender richtig verstanden habe, liegt der Fehler an den SecAssessment Sicherheitseinstellungen liegen sollte.

Gruß
Marco


#3

vielen Dank für die Antwort. Ich habe natürlich vorher selbst schon nach einer Lösung gesucht und bin auf diese Seite gestoßen. Leider hat die vorgeschlagene Lösung nicht funktioniert.


#4

So selbstverständlich ist das leider nicht. Es wäre hilfreich und auch höflich der Community gegenüber, wenn Du mitteilen würdest, was Du schon weißt und ausprobiert hast, usw.


#5

Der Fehler sagt mir überhaupt nix.

Ist das beim Online Update passiert? Dann würde ich mal probieren die App in den Mülleimer zu verschieben und neu zu laden.

Und wenn das nicht funktioniert, auch das Workspace Verzeichnis zu löschen: ~/Library/Application Support/name.abuchen.portfolio.product/workspace


#6

Hat leider beides nicht geholfen. Gibt es irgendwo einen download Link für die Version 0.31? Dann kann ich zumindest testen, ob es nur mit der neuen Version auftritt oder ob sonst irgendwas an meinem System kaputt ist.


#7

Bei mir laeuft 0.32 unter OSX 10.13.5 problemlos.


#8

Hier:

https://bintray.com/buchen/downloads/download_file?file_path=0.31.2%2FPortfolioPerformance-0.31.2-macosx.cocoa.x86_64.tar.gz

Aber Deine Fehlermeldung ist schon interessant. Mit Version 0.32.0 packe ich ein Java JRE direkt mit in den App Folder ein. Damit entfällt das lästige Installieren von Java, die Fehlermeldungen wenn man “nur” das JRE hat und die blöde Nachfrage nach dem “Legacy Java 6”.

Allerdings wird das JRE nur nach installiert wenn man auch vorher schon ein solchen Bundle installiert hatte. Und die hatte ich vor ein paar Wochen nur einen Tag auf dem Download Server (und dann aus Lizenzgründen erst mal wieder runtergenommen). Du müsstest im alten App bundle nachschauen ob Du eine solche Installation hattest.

Vielleicht ist der Link von @Ragas gar nicht so abwegig. Ich würde mal alles wegwerfen (ausgepacktes App bundles und workspace), dann neu booten, und noch mal neu installieren. Oder doch die SystemPolicy ersetzen (aber eine Kopie behalten)?

BTW, ich entwickle unter 10.13.5 - da läuft es auch…


#9

Vielen Dank für den Link. Leider lässt sich nun auch 0.31 nicht mehr starten, mit der selben Fehlermeldung. Ich versuche nochmal, alle Spuren von PP zu entfernen und neu zu installieren.


#10

Nach dem Aufräumen und neu installieren lief es immer noch immer nicht…
Aber irgendwas war wohl mit Gatekeeper auf meinem System im Eimer. Ich konnte das Problem dennoch folgendermaßen lösen:

  1. Gatekeeper global mittels “sudo spctl --master-disable” deaktivieren
  2. PP starten (funktioniert jetzt) und gleich wieder beenden
  3. Gatekeeper global mittels “sudo spctl --master-enable” wieder aktivieren

Mal sehen, ob es nach dem nächsten Reboot noch immer funktioniert.
Jedenfalls mal vielen Dank an alle hier!