Wie kann ich einen Proxy konfigurieren?


#6

Hallo,
ich sitze hinter einem Corporate Proxy mit Authentifizierung. Den Proxy habe unter Einstellungen in PP eingetragen.

Benutzername und Passwort habe ich in der PortfolioPerformance.ini eingetragen, aber es funktioniert nicht. Im Fehlerprotokoll bekomme ich Error 407 (Proxy Authentifizierung):

Hat jemand einen Idee?

Gruß Jan


#7

Welche Authentifizierungsverfahren werden denn unterstützt?
Wird Benutzername/Passwort überhaupt unterstützt? Und falls ja, hast Du den richtigen Benutzer (+ Passwort)? Richtig in dem Sinn, dass der Proxy diesen Benutzer (+ Passwort) als berechtigt zur Nutzung des Proxy ansieht. Die Betreiber Deines Proxy sollten dazu Auskunft geben können.


#8

Das ist ein HTTP-Proxy mit Authentifizierung. Das funktioniert mit diesem Server/Port/Benutzer/Passwort in anderen Programmen (Firefox, Spotify, Dropbox…) auch problemlos.


#9

Wenn du Benutzername und Passwort benötigst, versuche bitte einmal dies wie folgt als Adresse einzugeben:

Passwort:Kennwort@Adresse

Der : trennt das Passwort vom Kennwort und das @ signalisiert das jetzt die Adresse des Proxys kommt.


#10

Evtl. die Domäne voranstellen, also im Format Domäne\Username .
Je nach Konfiguration kommt es auch auf Groß-/Kleinschreibung an.


#11

Hm, das funktioniert leider alles nicht.

Ich habe mir bei GitHub mal das Coding angeschaut, es gibt da wohl zwei Stellen welche Proxy Authentifizierung behandeln, aber so ganz erschließt es sich mir nicht:

Kann jemand daraus ableiten wie das funktionieren könnte? Hab mal folgendes in die ini geschrieben, aber das funktioniert aber auch nicht:

-http.proxyHost=my.proxy.de
-http.proxyPort=8080
-http.proxyUser=myUser
-http.proxyPassword=myPassword

Gruß
Jan


#12

Ich habe jetzt als Workaround lokal einen Proxyserver (CCProxy) installiert, welche selber ohne Authentifizierung arbeitet und alle Anfragen an den Corporate Proxy weiterleitet (und dabei Benutze/Passwort mitgeben kann).

In Portfolio Performance trage ich dann diesen lokalen Proxy ein…


#13

Bei einem HTTP proxy ohne Authentifizierung bekomme ich aber auch keine Verbindung hin. Wie prüft man die Verbindung? Auch wenn “Nach Aktualisierung prüfen” immer “Keine Updates vorhanden” liefert, bekomme ich keinen einzigen Kurz über Yahoo, sondern immer nur “Börsenplatz fehlt”.


#14

Siehe fehlendes Symbol bei deinen Wertpapiere:


#15

Nein, daran kann es nicht liegen, ich habe unter Stammdaten das Symbol eingetragen, das ich z.B. bei der boerse-frankfurt.de ablesen kann.
Ich glaube eher, dass die Proxy-Verbindung nicht funktioniert. Allerdings müsste dann auch eine Fehlermeldung hochkommen, dass die Verbindung scheitert, statt nur “Börsenplatz fehlt”. Wie kann ich die Proxy-Verbindung testen?


#16

Die Proxy-Unterstützung scheint fehlerhaft zu sein.
Obwohl ich als Server gateway01 und als Port 8080 eingetragen habe, macht der java Prozess eine Verbindung auf zu einer IP in der yahoo.com Domain auf 443.

Weiterhin sollte die Software auch die Environment Variablen berücksichtigen, respektive $https_proxy, $http_proxy, $no_proxy. Man sollte so, wie es die meisten Browser tun, diese Möglichkeiten in der Konfiguration haben:

[ ] Direct internet connection (no proxy)
[ ] Manual Proxy Configuration
[ ] Use System Proxy Settings

Zumindest sollte das explizite Setzen eines HTTP Proxy repariert werden.


#17

Das hört sich nach einem Bug an. Ich habe das schon lange nicht mehr getestet… :unamused:

Kannst Du mir mal Deine Environment hier posten (Hilfe -> Über Portfolio Performance -> Installationsdetails)? Nur um zu sehen, ob nicht doch Java Environment da reinspielt.


#18

Der Text war zu lang, daher als Anhang: portfolio.txt (30,7 KB)


#19

Achja, und die übliche Unterstützung der Proxy-Typen http und socks5 wäre hilfreich, ich möchte aber nicht zuviel verlangen.
Ich frage mich sowieso, warum jeder immer die Proxy-Unterstützung selbst stricken muss, das gab in vielen Projekten schon Probleme wie Jameica (auch Java) und selbst da in diversen Addons. Der Proxy Bereich ist meist wenig getestet.


#20

Hattest du nach dem Proxy-Support mal schauen können, oder habe ich da etwas falsch konfiguriert?


#22

Ich habe es kurz mit dem unserem Corporate Proxy ausprobiert. Da habe ich keine Probleme und PP lädt Daten. Deswegen fehlt mir etwas der Ansatzpunkt für die Fehlerbehebung.

Viel falsch kann man da ja nicht konfigurieren…

Und das sieht auch okay aus:

http.nonProxyHosts: localhost|127.0.0.1
http.proxyHost: http://gateway01
http.proxyPort: 8080
http.proxySet: true
https.nonProxyHosts: localhost|127.0.0.1
https.proxyHost: http://gateway01
https.proxyPort: 8080
https.proxySet: true

Nur zum Verständnis: Bei Dir funktioniert eine Kursabfrage mit dem Lieferant “Yahoo Finance” nicht? Oder werden die Börsenplätze nicht gelesen? (ersteres ist via Yahoo API, letzteres ein Callback von der Webseite).


#23

Ich bin neu bei PP (genau das was ich lange gesucht habe, um meine Libreoffice Tabellen zu ersetzen), weiß daher nicht genau, wie es normalerweise funktionieren sollte.
Ich gehe auf Alle Wertpapiere, z.B. Netflix, Editieren. Unter Stammdaten pflege ich das Symbol “NFC” nach. Kann man das nicht automatisieren, da ISIN und WKN ja aus dem Consorsimport bekannt sind?
Nun gehe ich auf Historische Kurse, Lieferant Yahoo Finance, Börsenplatz ist ausgegraut und ich habe die Fehlermeldung “Börsenplatz fehlt”.

Derweil öffnet PP folgende Verbindungen:
# netstat -atpn |grep java
tcp 0 1 10.190.126.14:55674 87.248.118.23:443 SYN_SENT 17672/java
tcp 0 1 10.190.126.14:55628 87.248.118.23:443 SYN_SENT 17672/java

Das sind yahoo.com IPs, da müsste eigentlich der Proxy stehen.
Bist du sicher, dass deine Verbindung wirklich über den Proxy geht und nicht doch einfach direkt?


#24

Hab nun ohne Proxy Kurse von Yahoo Finance abrufen können, der Proxy-Support funktioniert nicht. Hast du schon etwas rausgefunden hierzu?


#25

Ich habe das Problem gefunden. Mit einer meiner letzten Änderungen habe ich den Proxy Support wieder ausgebaut. Das fixe ich. Kommt mit der nächsten Version (vielleicht dieses WE).


#26

Mit Version 0.33.1 sollte die Proxy Konfiguration wieder für Yahoo und Kraken gezogen werden.