Zahlenformat (Dezimaltrennzeichen) ändern

Hallo zusammen
Zuerst möchte ich sagen, dass ich sehr beeindruckt von PP bin. Sowohl was den Funktionsumfang wie auch die jeweilige Implementierung betrifft. Einfach alles da, was zu einer Top-Portfolio-Software gehört! Da ich mich eine Zeitlang selber an java unter Eclipse versucht habe, weiss ich, was da an Knowhow und Aufwand drin steckt. Ein riesengrosses Dankeschön für dieses tolle Programm!
Ein kleines Problem habe: Wie schaffe ich es, dass Zahlen mit einem Punkt anstatt einem Komma als Dezimaltrennzeichen dargestellt werden (‚Schweizer‘ Zahlenformat anstatt deutsches). Habe im Forum und diversen Youtube-Videos vergeblich nach einer Antwort gesucht, und hoffe, ich stelle mich nicht einfach nur saudumm an. Vielen Dank für eine Antwort.

1 Like

Hallo moonsedge,

herzlich willkommen hier im Forum.

Ich befürchte, dass das Zahlenformat mit der Sprache verbunden ist. Du müsstest dann z.B auf Englisch umstellen … oder eine neue Lokale schreiben.

Hallo Harry_Hirsch

Danke für die wirklich schnelle Antwort. :smile:

Inzwischen habe ich mein OS (Ubuntu) versuchsweise auf die US-Locale umgestellt, was aber in PP nichts bewirkt hat. Ebenso wenig das Zurückstellen auf die ursprüngliche CH-Locale. Dezimalpunkt ist und bleibt in jedem Fall das Komma.
Weiter habe ich das gleiche Problem von je her auch auf meinem älteren Win7 Notebook (mit CH-Locale), auf dem ich PP seit Juni installiert habe. Mir scheint, dass ich grundsätzlich etwas falsch zu mache oder nicht richtig verstehe.
Gibt es in PP vielleicht eine editierbare (Text) Config-Datei, die die Locale-Einstellung von PP steuert?

Gerade ein wenig gegoogelt, nachstehender Zusatz beim Aufrufen der PortfolioPerformance.exe ändert das Zahlenformat von 1.234,56 auf 1’234.56 . Hilft das?

PortfolioPerformance.exe -nl de_CH

Java bzw. Eclipse orientiert sich nicht an den Vorgaben vom PC, daher hilft es auch nicht die Einstellungen bzgl. Zeilenformatierung anzupassen :wink:

Gruß
Marco

2 Likes

Hallo Marco

Das hilft enorm! – Es ist die Lösung, danke! :joy:

Nun ärgert mich nur noch, dass ich nicht selber drauf gekommen, die Lösung bei einem Java-Startparameter zu suchen und entsprechend zu googeln. Das einzige, was ich zu meiner Entlastung anführen kann: Ist schon eine Weile her mit mir und Java unter Eclipse.

Nochmals ganz herzlichen Dank!

Benutze PortfolioPerformance.app unter macOS, hatte dasselbe Problem. Konnte es lösen, indem ich die Applikation über die Kommandozeile so starte:

/Applications/PortfolioPerformance.app/Contents/MacOS/PortfolioPerformance -nl de_CH

Muss jetzt noch schauen, wie ich den Parameter bei jedem Start, auch nicht über die Kommandozeile, benutzen kann.

Als Win User schlägt mir Google für Mac folgendes vor (original f. Firefox):

Open Automator and create an Application with a single Run Shell Script action:

/Applications/PortfolioPerformance.app/Contents/MacOS/PortfolioPerformance -nl de_CH

This application will launch PP and quit instantly, leaving only PP running.

Genau so habe ich das gemacht. :slightly_smiling_face:

Wen es interessiert, so kann man das Programm im Hintergrund starten. Der oben gezeigte Befehl gibt nämlich die Konsole nicht mehr frei.

/Applications/PortfolioPerformance.app/Contents/MacOS/PortfolioPerformance -nl de_CH >/dev/null 2>&1 &

Gibt es da keine andere Option um das Programm auch beim Start über die Spotlight Search entsprechend zu starten? Es ging nämlich eine ganze Weile so und ist erst seit ein paar Releases kaputt.

image
Wenn ich Language & Region für Apps setzen kann, dann eventuell auch mit korrektem Support für CH (die nunmal den Punkt als Dezimaltrennzeichen nutzt)?

Ich beschreibe es mal für Windows, für Mac sollte es identisch sein, weiss aber nicht, wo die zugehörige Datei liegt und bin gerade zu faul zu googeln :wink:

Vom Startmenü beim PP-Eintrag rechts draufklicken und “Dateispeicherort öffnen” auswählen. Das liefert einem erst mal den Ort der Verknüpfungen aus dem Startmenü:

Da beim PP-Eintrag wieder rechts draufklicken und “Dateipfad öffnen” auswählen. Jetzt sind wir im Installationsverzeichnis, wo sich eine PortfolioPerformance.ini finden sollte:

grafik

(Mac-/Linuxuser sollten ab hier wieder mitspielen können).

Die ini-Datei macht man mit dem Texteditor seiner Wahl (auf Windows z.B. notepad, überall sonst natürlich vim) auf und sieht dann etwas in folgender Art:

grafik

Hier ganz an den Anfang das -nl und de_CH einfügen. Am einfachsten an den Anfang und jeder Wert in einer einzelnen Zeile:

grafik

Ab da erscheinen Zahlenwerte auf “Schwyzerdütsch” :wink:

Was ich nicht weiss und/oder garantieren kann, ist dass die Änderung erhalten bleibt, wenn ein Update eingespielt wird.

Einfacher wäre allerdings, es in den Einstellungen zu ändern, wie es seit Version 0.56.5 geht.