Date Format issues with JSON quote feeds

I’m trying to load the following URL:

as a JSON quote feed. I’ve set the following:

but as you can see I’m getting

Text ‘1591185600’ could not be parsed at index 0

From the instructions in the UI given this is an epoch date, I shouldn’t need to specify a date format? I had a look at and it appears to be because the field is defined as a string, rather than a number.

I tried using the ‘dateF’ field in the JSON - which comes in a somewhat crazy format of “Wed Jun 03 10:00:00 PM GMT 2020”. Unfortunately the closest Java date format string I can find is: “EEE MMM dd hh:mm:ss a zzz yyyy” but the DateTimeFormatter chokes on the AM/PM field with hh:mm:ss or HH:mm:ss. Any ideas?

Many thanks

Regarding AM/PM, the strings expected by a depend on the locale. So using a different locale might work.

Maybe it is easier to use onvista?


seems to be GB00BL68HJ26{TODAY:yyyy-MM-dd:-P1M}

How to handle with onvista is written down in Historische Kurse von onvista nicht mehr lesbar - #78 by chirlu and following posts.


@chirlu, thanks - locale is set to en_GB - I tried just running java code outside of portfolio performance and had the same issue - I suspect it’s a bug/limitation in the Java library.

I’ve actually managed to work around it though. The ‘12:00:00 PM GMT’ portion is unchanging, so I flipped the format to a literal, ie EEE MMM dd '12:00:00 PM GMT' yyyy, so that will do the trick for now!

@ProgFriese, thanks - I hadn’t come across onvista, that’s a good one to have in my back pocket!

1 Like