ETF-Stammdaten von etf-data.com

Hallo @AndreasB,

das ist eine supercoole Funktion mit Mehrwert.

Vielen Dank dafür.

Mir ist aufgefallen, dass z.B. bei einem ETF auf MSCI Wolf nicht alle Anteile in die Klassifikation z.B. der Länder einsortiert werden können, sondern ein „Rest“ unter „nicht klassifiziert“ verbleibt.

Ist das normal?

Viele Grüsse

Thomas

Ja, denn es muss nicht immer drin sein was drauf steht. Oder der Anbieter hat die Länder schlicht nicht klassifiziert.

zumal ich gerade sehen, das ich MSCI Wolf :wolf: geschrieben habe :slight_smile:

kannst du noch ein paar Worte schreiben, was Du damit meinst?

Wenn du im Gegenzug die ISIN nennen könntest müsste man nicht raten :wink:. Das was den Index beschreibt muss nicht zwangsläufig auch im Inhalt stecken. Bspw kann ein synthetischer ETF auf Japan ausschließlich deutsche Wertpapiere beinhalten usw.

Zudem hält jeder ETF immer eine gewisse Menge an Cash (Dividenden, die noch nicht ausgeschüttet bzw. wieder angelegt wurden). Dieser Anteil taucht logischer Weiser nicht in den Regionen/Sektoren auf.
Aber wie @Ragas schon sagte, wenn du eine ISIN nennst, kann man über das Factsheet bzw. vielleicht auch den Eintrag auf etf-data.com genau sagen, was der nicht kategorisierte Rest ist.

@Ragas
@AndreasB

Bei mir funktioniert es leider immer noch nicht :slightly_frowning_face:

Ich habe -so glaube ich- alles korrekt eingestellt?-:

Im Fehlerlogger sieht man „nur“ dass ein paar Fehler (Fehlercode 404) auftauchen, weil auch ISIN von Aktien gesendet wurden (Fehlerlogger ab 14:22 Uhr).
Dann wird abgebrochen :-((
Abbruch durch:
image
Die Attribute wurden auch nicht erweitert:

Mit der Kommer Beispieldatei funktioniert alles super (Fehlerlogger 14:20 -14:21 Uhr).

Könnt Ihr mir bitte helfen?

MfG

Axel

pp-error-2021-01-13.log (751,4 KB)

1 Like

Dieser Beitrag wurde von der Community gemeldet und ist vorübergehend ausgeblendet.

https://forum.portfolio-performance.info/t/etf-stammdaten-von-etf-data-com/13363/10?u=ronnyg

Das ist ja das was ich weiter oben schon mal versucht hab zu schildern. Sobald ein klassischer Fond abgerufen wird, hakt es und nichts wird synchronisiert. Bei Einzelaktien Abfrage gibt es zwar auch eine 404 Fehlermeldung, aber es geht dann wenigstens weiter im Programmablauf. Dein Pioneer Fond ist ein klassischer Fonds und verursacht das Problem.

@Ragas und @SgtWinter

Z.B. dieser hier: FR0010315770

Okay, das ist noch ein Programmierfehler :unamused:
Für einige Papiere gibt es keine TER - und ich erwarte aber eine Zahl. Grrr.
Das behebe ich mit der nächsten Version.

Leider gibt es für Dich gerade keinen einfachen Workaround - Du könntest die ISIN ja temporär rausnehmen, wenn Du denn wüsstest um welche es sich handelt.

1 Like

@Thomas12
Danke für die ISIN.

Ohne das ich jetzt die Zuordnung gegen prüfe, für diesen ETF können 99,98% zugeordnet werden. Ob und welche Zuordnung als Rest zugeordnet werden weiß ich nicht

Code Name Anteil
ARG Argentina 0,15
AUS Australia 2,27
AUT Austria 0,05
BEL Belgium 0,28
BMU Bermuda 0,08
CAN Canada 3,16
CHE Switzerland 3,04
CHL Chile 0,02
CHN People’s Republic of China 0,15
DEU Germany 2,88
DNK Denmark 0,8
ESP Spain 0,76
FIN Finland 0,32
FRA France 3,34
GBR United Kingdom (Great Britain) 4,26
HKG Hongkong 0,95
IMN n/a 0,02
IRL Ireland 0,25
ISR Israel 0,19
ITA Italy 0,65
JOR Jordan 0,01
JPN Japan 7,73
LUX Luxembourg 0,07
MEX Mexico 0,01
NLD Netherlands 1,47
NOR Norway 0,17
NZL New Zealand 0,12
PRT Portugal 0,05
RUS Russia 0,01
SGP Singapore 0,32
SWE Sweden 1,05
USA United States 65,25
ZAF South Africa 0,08
ZMB Zambia 0,02
1 Like

@AndreasB Hätte mal drei Fragen:

  1. Wo in den Klassifikationen sollte ich denn die TER finden (hab gesucht und nicht gefunden)
  2. Datenabrufe:
    2a) Werden die Daten bei jedem Aufruf neu zugeordnet
    2b) Auch die neu hinzugenommene Klassifikationen
  3. Hab noch nicht in etf-com recherchiert: Kann man denen ein ETF senden, das von denene noch nicht klassifiziert ist: IE00BFYN8Y92 HANetf-EMQQ Em.Mkts Int.+Ecom.
    Jokerfrage 4 :wink: Kümmert sich jemand um Aktien (die können ja auch mehreren Branchen zugeordnet sein)
    Danke für Deine Arbeit. Das wertet PP super auf .
    Gruß progro

Gefahr erkannt - Gefahr gebannt :slightly_smiling_face:

Zu 1.: die TER ist ein Atribut und nicht in einer Klassifizierung zu finden.
zu 3.: klar kannst du denen eine ISIN zusenden, ist ein freies Land :wink: Was die dann machen, musst du selbst abwarten, das wird dir kein außenstehender seriös beantworten können.
zu 4.: du selbst. :wink:

2 Like

Erstmal vielen Dank für diese Funktion, das ist teilweise sehr hilfreich! Leider nur teilweise, aufgrund der oben schon angesprochenen Problematik mit „falschen“ Klassifikationsdaten. Aber das liegt eindeutig an etf-data, die dort hinterlegten Daten sind unvollständig.

Bei manchen ETFs klappt es super (99,8% klassifiziert, der Rest ist vermutlich Bargeld o.ä.) und bei manchen ist es etwas ungenau (das wäre durch Synthetik oder Sampling erklärbar), aber manchmal weichen die etf-data-Daten einfach zu stark ab und ruinieren die gesamte Klassifikation. Z.B. ist der optimiert gesamplete IE00BTJRMP35 mit 52% China und 18% unklassifiziert hinterlegt, obwohl nur 36% China und <1% unklassifiziert drin sein sollte; ich habe auch noch ein paar „vollständig replizierte“ mit 5-10% Abweichung.

Ich würde mich freuen, wenn man irgendwo (vielleicht im Stammdatenfenster?) eine flag setzen könnte für „dieses Wertpapier nicht mit etf-data synchronisieren“. Dann könnte ich die groben Fehler von Hand korrigieren und dann unverändert behalten, aber trotzdem für die anderen Wertpapiere von der super Funktion profitieren.
VG

4 Like

Die NPE sollte jetzt mit Version 0.50.2 nicht mehr auftreten. @acdc014 - willst Du noch mal probieren?

1 Like

Ich denke mal aber nur für eine bestimmte Klassifikation, oder? Die anderen Attribute wie TER, etc. würde man doch wohl noch synchronisieren wollen.

Gleich Morgen früh :blush:

Hallo,

habe nun den Test durchgeführt:

  • Synchronisierung funktioniert - bis zum Abbruch durch " Unfortunately your free requests have expired. "

Dadurch, dass ich mir die Mühe gemacht habe, meine Wertpapiergeschäfte seit 1991 nachzutragen, werden natürlich sehr viele Fonds und Aktien synchronisiert, die etf-data nicht kennt. Teilweise gibt es die gar nicht mehr…

Nun habe ich entsprechend den Tipps aus dem Forum in der Fritzbox mehrfach die Internet-IP neu vergeben lassen.
Das funktioniert prinzipiell - allerdings komme ich nicht so weit, das alle ETF klassifiziert werden (wegen der vielen Aktien und alten Fonds)

@AndreasB
Vielleicht wäre es eine (einfache) Lösung die Option einzuführen: "Sync von ETF-data.com (selektierte Wertpapiere)"
Was meinst Du ?

Nochmals Danke für die schnelle Fehlerbehebung! :+1: :+1: :+1:

Axel

@AndreasB

Zusatzfrage zu den Klassifizierungen von ETF-Data.com:
(sorry konnte es nicht mehr als „Antwort“ in das Thema schreiben, da ich dort schon 3 Antworten gegeben habe)

Sind die im Screenshot unten dargestellten Asset Allocation’s von ETF-Data nicht falsch zugeordnet? Gehören die nicht unter „Risikobehafteter Portfolioanteil“?

Kann ich die einfach unter „Risikobehafteter Portfolioanteil“ schieben/zuordnen - oder funktioniert dann die Zuordnung über ETF-Data nicht mehr???

MfG

Axel

Aber wahrscheinlich hätte ich bei „Asset Allocations“ gar nicht die Synchronisierung (rechts oben unter „Wolke“) aktivieren dürfen - oder?