Filter not saved properly when used on multiple PCs


I’m trying to use PP on 2 different computers. I have a problem wich my xml, as it appears not to save filters properly.

When I add a Widget on Dashboard and select data series for it and choose my custom filter “Dom” it will show the info for that filter, for an instance it will show me Absolute Performance for all of the accounts that are part of the “Dom” filter. Unfortunately when I save and open this xml file on another PC, the Absolute Performance is no longer for Dom, but for Entire Portfolio.

It looks like filters aren’t saved in xml, as well as data series for widgets.

Thank you, that solved the problem. I didn’t really knew how to name it in order to find it.

There’s another problem though. The initial value and final value of my portfolio differes between PC significantly. I don’t know why. The difference is big, around 5% on final value.

I think the difference comes from the securities denominated in foreigh currency, but on both PC’s they’re up-to-date. How can I fix this?

Exchange rates are downloaded from the website of the European Central Bank. Is there perhaps a firewall on PC 2 that prevents that?

Yep, this is very possible. When I go to General Data > Currencies there are no graphs. The latest exchange rate is from 2015. xD

I don’t think I can change the protection settings, as I’m not the administrator.

Can I update it manually?

Unfortunately not.

You can manually create the exchange rates (in the “All securities” section). They will override the values from the ECB.

But before that, let’s find out what the underlying problem might be. Can you send me an email with the full error protocol? First, reproduce the error: stop PP, start PP. Then go to Help → save error protocol. Send it to portfolio dot performance dot help at gmail dot com.

Hi, thanks for help.

I’ve just sent the log file.

Hi @Candy6132,

PP downloads the ECB exchange rates from this site: Euro foreign exchange reference rates

Interestingly, I do not see any failed request to the ECB in the log. I see, however, lot’s of other failing requests, for example:

Connect to [...] connect timed out
Connect to [...] connect timed out
Connect to [...] Connection refused: connect

Your machine is blocking many (all?) connections.

As said, at the moment one cannot manually update the ECB rates. It is a binary file. It is shared by the whole installation and used for all XML data files.

What you can do however, is manually create exchange rates. These data series are stored inside the XML and are available also offline. Details can be found here Währungen (it is in German - use the version translated by Google Translate)

Is the binary file in any way specific to the installation, or to the OS? If not, @Candy6132 might synchronize it from PC 1 to PC 2 in the same way as the portfolio and settings files. In case it is OS specific, it might still work if PC 1 and PC 2 run the same OS.

You are right. It is not specific to the installation or OS.
The file is called ecb_exchange_rates.pb.

On my installation it can be found here


And also keep in mind, that it must be regularly updated with the latest rates.

It’s the same OS. Thanks, I’ll try this approach.

Creating custom exchange rate would mean, I will have to modify most of the securities I already have in the history. Also this would force me to manually update it on PC1.

Ok, here’s another problem. I can’t find the ecb_exchange_rates.pb on PC2. It’s a Windows Zip version. It wasn’t installed, just copied on drive. Where should I put the file?