Kein Scrollbalken bei Währungsauswahl (Linux)

Hallo zusammen.
Ich benutze PP neu. Habe aber das Problem seit dem Anfang. Auch das Update auf 0.43.0 ergab keine Änderung.
Nun zu meinem Problem:
Wenn ich irgendwo die Währung auswählen muss, bekomme ich kein Auswahlfenster, welches ich scrollen kann. Sondern die Währungen werden vom oberen bis zum unteren Bildschirmrand aufgelistet. Aber leider nur von AED bis ETB. Der Rest fehlt, es ist auch keinen Scrollbalken vorhanden.
Ich benutzte Linux Debian 10.2 64bit Version. Ich habe es mit dem Open Java und der oracle Java Version 1.8.0 getestet. Leider keinen Unterschied.
Ich hoffe, ihr könnt mir helfen.
Gruss rohtechni

Scrollbalken habe ich auch nicht


aber das Mausrad funktioniert. Das Du die kleinen Pfeile nicht siehst liegt vielleicht an Deinem verwendeten Theme / DarkMode / Whatever?

Hallo ProgFriese
Danke für deine schnelle Antwort und Hilfe.
Nein, mit der Maus geht es auch nicht.
Ich habe deinen Tipp mit den Themen befolgt. Leider zuerst ohne Erfolg.
Aber als ich weiter mit den Themen herumgespielt habe, hat es plötzlich funktioniert.
Ich habe dann herausgefunden, dass ganz wenige Themen funktionieren. Es liegt den Themen „Steuerung“ Warum auch immer?
Ich finde dies eigentlich sehr schade…

Vorher:

Nachher:

Aber besten Dank für deine Hilfe. Darauf wäre ich nie gekommen.

Gruss rohtechni

Leider habe ich festgestellt, dass das Problem nicht ganz behoben ist.
Wenn ich in der Vermögensaufstellung die Währung wechsle, ist das Phänomen immer noch vorhanden.

Ich hoffe, jemand hat noch eine Idee.

Danke und bis bald.

Kann es möglich sein, daß du wieder ein Theme verwendest, was nicht kompatibel ist? Das verrät zumindest die Checkbox…

Erst mal Danke.
Ich habe schon alle Theme durch, aber leider hat keines geklappt.
Was meinst du mit Checkbox?

In dem einem Screenshot schaut alles gut/besser aus, in dem letzten ist bei jeder Währung ein Kästchen zum anhaken…

Ok, danke für den Hinweis.
Ja, die Kästchen sind mittlerweile da, aber scrollen geht leider bei der Vermögensaufstellung immer noch nicht.
Ist das nur bei mir so oder wird Linux nicht viel genutzt?

Zumindest sieht es so aus, evtl liegt es
an der Java Version für dein OS in Verbindung mit dem Theme. GTK könnte auch beteiligt sein.

However so alleine bis du aber nicht. Letzten Monat wurde die Linux Version ~800 mal heruntergeladen, was knapp 8% entspricht.

Schwierige Frage :wink: Es kommt wahrscheinlich auch auf das Derivat und die gewählte Oberfläche an.

Ich benutze z.B. xfce und bei mir funktionieren die Donut-Diagramme nicht. Kann ich aber mit leben. Nach längerem Ausprobieren habe ich festgestellt, daß PP bei mir am besten läuft mit den Zeilen

--launcher.GTK_version
2

am Anfang der PortfolioPerformance.ini

Ich nutze noch

$ java -version
openjdk version "1.8.0_232"
OpenJDK Runtime Environment (build 1.8.0_232-8u232-b09-0ubuntu1~18.04.1-b09)
OpenJDK 64-Bit Server VM (build 25.232-b09, mixed mode)

Falls Du auch xfce nutzt, probier das doch mal aus. Oder verrate was Du nutzt, eventuell findet sich hier auch noch ein Gnome-, KDE- oder sonstwas-Nutzer, der eine Idee hat.

Hallo ProgFriese

Ich nutze Java von oracle:

java version „1.8.0_231“
Java™ SE Runtime Environment (build 1.8.0_231-b11)
Java HotSpot™ 64-Bit Server VM (build 25.231-b11, mixed mode)

Meine Oberfläche ist Cinnamon 3.8.8 mit Debian 10.2 (x86-64)

Ich habe deinen Rat befolgt und

eingefügt.

So weit läuft alles einwandfrei. Auch die Theme kann ich wieder alle verwenden.
Herzlichen Dank!!
Aber ich habe nun dasselbe Problem wie du.

Aber damit kann ich auch leben.
Ich denke, da stecken einfach noch kleine Bug in der Linux Version, damit es auf allen Distributionen läuft.

Ich bekomme folgenden Hinweis, wenn ich die Donut-Diagramm (Bestände) öffne:

Fehler beim Öffnen des Web Browsers zur Darstellung der Grafiken

  • Aktuelleste Version des Browsers installiert?
  • Unter Linux muss das Paket libwebkitgtk-1.0-0 installiert sein.

Der Fehlertext
„No more handles [Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]“
heisst meistens, dass libwebkitgtk installiert werden muss. Unter Ubuntu 14.4 z.B. mit
sudo apt-get install libwebkitgtk-1.0-0

Details:
org.eclipse.swt.SWTError: No more handles because no underlying browser available.
SWT on GTK 2.x detected. It is reccomended to use SWT on GTK 3.x and Webkit2

Auf GTK2 haben wir ja bewusst umgestellt. Aber wie kann ich prüfen welcher Webkit genommen wird, bzw. wie lautet der Befehl das PP den Webkit2 nimmt.
Den verlangten libwebkitgtk-1.0-0 gibt es nicht mehr in der Paketverwaltung.

Kenn sich da jemand aus?

Du kannst Dir https://launchpad.net/ubuntu/+archive/primary/+files/libwebkitgtk-1.0-0_2.4.11-4_amd64.deb bzw. http://ftp.br.debian.org/debian/pool/main/w/webkitgtk/libwebkitgtk-1.0-0_2.4.11-3_amd64.deb (falls Dir das ältere Original lieber ist) runterladen und dann

sudo apt install libwebkitgtk-1.0-0_2.4.11-4_amd64.deb
bzw.
sudo apt install libwebkitgtk-1.0-0_2.4.11-3_amd64.deb

Das Du dann mehrere Versionen hast tut nicht weh. Ich hab auch mehrere:

$ dpkg -l | grep libwebkit
ii  libwebkit2gtk-4.0-37:amd64            2.26.2-0ubuntu0.18.04.1                         amd64        Web content engine library for GTK+
ii  libwebkitgtk-1.0-0:amd64              2.4.11-3ubuntu3                                 amd64        Web content engine library for GTK+
ii  libwebkitgtk-3.0-0:amd64              2.4.11-3ubuntu3                                 amd64        Web content engine library for GTK+

Donut bei Bestände funktioniert bei mir.

Danke für den Hinweis

Ich musste aber weg der Abhängigkeit noch zwei zusätzliche Pakete installieren:
libicu57_57.1-6+deb9u3_amd64.deb Download-Link
libjavascriptcoregtk-1.0-0_2.4.11-3_amd64.deb Download-Link
Dann konnte ich erst
libwebkitgtk-1.0-0_2.4.11-3_amd64.deb
installieren.
„libwebkitgtk-1.0-0_2.4.11-4_amd64.deb“ konnte ich nicht installieren. Bekam immer eine Fehlermeldung.

Übrigens musste ich mit "sudo dpkg -i …deb installieren.

Nachdem ich alle 3 Pakete installiert hatte, funktionierte auch der Donut bei den Beständen wieder.
Zurzeit kann ich keinen Fehler mehr bei mir finden.
Nochmals herzlichen Dank für deine Hilfe.

Welche Donut-Diagramme gehen bei dir nicht, bzw. wo finde ich diese im PP?

Unter Klassifizierungen / Asset Classes z.B

Asset Allocation funktioniert manchmal (hab noch kein System entdeckt)

Das ist bei mir auch so.
Wenn ich das Donut-Diagramm zu ersten Mal anklicke geht es nicht, wenn ich aber eine andere Klassifizierung anklicke und dann zurück auf die vorhergehende klicke, wird die Grafik angezeigt.

Warum auch immer.

Dieses Thema wurde automatisch 30 Tage nach der letzten Antwort geschlossen. Es sind keine neuen Nachrichten mehr erlaubt.