Logos werden links abgeschnitten

Erstmal Danke für das tolle neue Feature, so wirkt das alles gleich viel lebendiger.

Allerdings werden die Logos in so ziemlich jedem Modul außer „Alle Wertpapiere“ links ein Stückchen abgeschnitten bzw. es liegt wohl daran, wenn wie Standardmäßig (ist doch Standard oder?) die Bestandsspalte oder eine andere Spalte als erstes genutzt wird, dann scheint diese ein Stückchen vom Logo abzuschneiden. In den anderen Modulen wird das Logo nur sauber angezeigt, wenn ich die Namensspalte als erste Spalte verwende - da lässt sich doch sicher noch etwas optimieren?

In der Vermögensaufstellung ist es bei mir übrigens auch der Fall und nicht so sauber wie auf dem Screenshot im Ankündigungsthread

Zur Veranschaulichung. Einmal mit Bestandsspalte an erster Stelle & einmal mit Namensspalte an erster Stelle:

2 Like

Das Problem habe ich leider auch … :anguished:

Das Abschneiden taucht auch bei mir auf

Das ist bei mir auch so. Ich denke das liegt am Tablelayout. Leider bin ich noch draufgekommen wie das zu fixen ist, ehrlich gesagt habe ich die letzte Zeit bei der Hitze aber auch nicht viel Zeit investiert. Wollte nur kurz bestätigen dass das bekannt ist.

1 Like

Ich hab mir das heute mal angeschaut. Leider habe ich noch keine Lösung, aber es liegt an der Bestandsspalte.

Diese Spalte wird extra behandelt und manuell gerendert, ich glaube um die Kommastellen speziell zu behandeln. Irgendwas läuft da bei der Berechnung falsch sodass da ein paar Pixel rechts mehr sich irgendwie überschneiden. Wenn man diese Spalte ein bzw. aus oder auch verschiebt und die Anzeige neu ladet stimmt es teilweise, manchmal kommen aber auch ganz komische Sachen dabei raus.

Ich werd mal versuchen aber man das mit den Kommastellen nicht auch mit dem Std. Rendering hinbekommt, dann brauch man nicht manuell Fontwidth usw. auszurechnen.

1 Like

Ich bin mir ziemlich sicher, dass es nicht die Bestandsspalte ist. Warum? In der Wertpapierliste tritt der Effekt auch ohne Wertpapierspalte auf (siehe Screenshot; links die Logo-Spalte manuell eingebunden und rechts die Namensspalte) und in der Vermögensaufstellung mit der Bestandsspalte tritt der Effekt ebenfalls auf, doch dort habe ich noch eine andere Spalte zwischen Bestand und Name (mit dem Typ Betrag (einfach) - warum heißt das eigentlich nicht einfach „Zahl“?). Es musste also ziemlich sicher an der Namensspalte selbst liegen.

PP Beispiel Logo-Beschneidung

Hmm, die Vermögensaufstellung könnte aber durchaus auch noch ein zweites Problem beinhalten.

Szenario A: Logo, Namensspalte; Logo normal, Name abgeschnitten
PP Beispiel Logo-Beschneidung 02

Szenario B: Eigene „Zahl (einfach)“ Spalte, Logo, Name; Logo abgeschnitten, Name abgeschnitten
PP Beispiel Logo-Beschneidung 03

Szenario C: Bestand, Eigene „Zahl (einfach)“ Spalte, Logo, Name; Logo abgeschnitten, Name abgeschnitten
PP Beispiel Logo-Beschneidung 04

Bezüglich der Logo-Spalte scheint es daran zu liegen ob sie an erster Stelle steht oder nicht (habe auch andere Spalten an erster Stelle getestet, z.B. Kursdatum), da wird dann ebenfalls abgeschnitten. Die Namensspalte ist dagegen immer abgeschnitten (Edit: außer sie steht an erster Stelle) und unabhängig davon ob die Bestandsspalte davor steht oder nicht.

Edit: In der Wertpapierliste spielt es dagegen keine Rolle ob dort noch eine Spalte an erster Stelle steht, da wird die Logo-Spalte (als zweite Spalte) nicht abgeschnitten. Vermögensaufstellung und Wertpapierliste werden hier also aus irgendeinem Grund etwas anders behandelt. Es kommen also zwei unterschiedliche „Probleme“ zusammen.

Es ist sehr komisch, aber mir kam vor es liegt immer an der Bestandsspalte, wenn ich die weg mache UND die Ansicht neu lade scheint alles zu stimmen. Aber ich muss noch mal schauen. War etwas frustrierend gestern weil ich nicht genau verstehe wie das custom rendering funktioniert, hab mich mit den Zahlen gespielt aber irgendwie nix dabei raus gekommen.

In der Spaltenüberschrift, zwischen Bestands- und Namesspalte sieht man es am Besten, der Splitter ist da bei mir bei den Werten um ein paar Pixel weiter rechts als der Splitter in der Überschrift. So wie in der Überschrift ists aber richtig, meines Erachtens nach.

Bestand ganz weg und neu laden führt bei mir zu keinem anderen Ergebnis als oben beschrieben. Es kommt weiterhin darauf an ob die betreffende Logo Spalte (Logo bzw. Name) an erster Stelle steht