Startfehler nach Java Update auf 271

Hallo

hatte die Mitteilung beim Start von Portfolio, dass vor dem nächsten Updat eein Java Update notwendig ist.
Diesen habe ich durchgeführt. Nach dem nächsten PC-Start (mit autostart-Funktion von Portfolio) wurde wohl einiges „upgedatet“.
Aber eim Start kam dann ein Fehler log. Portfolio-Fehler-Meldung - 1610352618803.txt (188,9 KB)

Jetzt stehe ich vor dem Problem, was kann ich machen?

Hat es evtl. was damit zutun, dass ich (bedingt durch Speicherplatz-Probleme) das JRE auf eine andere Partition installiert habe oder ist es etwas anderes?

Karl

2 Like

Hallo,

bei mir trat nach Java-Update und Boot das gleiche Problem auf.

Johannes

1 Like

Ich habe ebenfalls das gleiche Problem. Thomas

Hallo zusammen,

ich erhalte weiterhin die Meldung dass ich Java Updaten soll, obwohl ich dies bereits 2 mal inkl. Neustart gemacht habe.
MacOS Catalina 10.15.7

Kann jemand helfen?Bildschirmfoto 2021-01-11 um 11.19.58

Hier auch! MacOS Catalina 10.15.7, nach Update auf Version 8 Update 271 von Java startet PP nicht mehr, sondern liefert nur die mir völlig unverständliche Fehlermeldung …

Das Java-Update hat definitiv funktioniert.

Same here I upgraded my Windows 10 to version Java 8 Update 271 (64 bit)
After that and rebooting PP no longer starts.
Errors like this in the log:
!ENTRY org.eclipse.equinox.p2.artifact.repository 4 0 2021-01-11 11:35:43.771
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.equinox.p2.artifact.repository [1470]
Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.repository
-> Export-Package: org.eclipse.equinox.internal.p2.repository; bundle-symbolic-name=„org.eclipse.equinox.p2.repository“; bundle-version=„2.5.0.v20201013-0853“; version=„0.0.0“; x-friends:=„org.eclipse.equinox.p2.artifact.repository, org.eclipse.equinox.p2.metadata.repository, org.eclipse.equinox.p2.updatesite, org.eclipse.equinox.p2.repository.tools, org.eclipse.equinox.p2.transport.ecf, org.eclipse.equinox.p2.engine, org.eclipse.equinox.p2.discovery.compatibility, org.eclipse.equinox.p2.publisher“
org.eclipse.equinox.p2.repository [1984]
Unresolved requirement: Require-Capability: osgi.ee; filter:="(&(osgi.ee=JavaSE)(version=11))"
Unresolved requirement: Import-Package: org.eclipse.equinox.internal.p2.persistence
-> Export-Package: org.eclipse.equinox.internal.p2.persistence; bundle-symbolic-name=„org.eclipse.equinox.p2.repository“; bundle-version=„2.5.0.v20201013-0853“; version=„0.0.0“; x-friends:=„org.eclipse.equinox.p2.artifact.repository, org.eclipse.equinox.p2.engine, org.eclipse.equinox.p2.metadata.repository, org.eclipse.equinox.p2.ui.importexport, org.eclipse.equinox.p2.repository.tools“

Attached the log1610361342056.log (269,7 KB)

Hier auch kein Start möglich.
Logfile:1610361758461.log (269,7 KB)

Habt ihr (entsprechend der Empfehlung, die im Screenshot zu sehen ist) PP mal neu heruntergeladen und installiert?

2 Like

Neuer Download hat tatsächlich geholfen. Dankeschön!

selbes problem: nach java update auf 271 unter linux mint 20.1 und pp-update auf 0.50 geht nichts mehr …

Hat bei mir auch geklappt, danke schön

ja, neuer download ohne effekt (linux mint 20.1)

MIt der Neu-Installtion war das Problem beim Starten der Anwendung dann weg…

Danke

It worked! I missed that part about also reinstalling PP I thought upgrading Java was enough!

Neu herunterladen hat geholfen! Klassischer Fall von „nicht zu Ende gelesen“ … :face_with_hand_over_mouth:

(evtl. ist diese rote Warnmeldung zu Beginn aber euch etwas unglücklich formuliert …?!?

Zeig mal die Ausgabe von

sudo update-alternatives --config java
  Selection    Path                                            Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-14-openjdk-amd64/bin/java      1411      auto mode
* 1            /opt/java/64/jre1.8.0_271/bin/java               1         manual mode
  2            /usr/lib/jvm/java-11-openjdk-amd64/bin/java      1111      manual mode
  3            /usr/lib/jvm/java-14-openjdk-amd64/bin/java      1411      manual mode
  4            /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java   1081      manual mode
  5            /usr/lib/jvm/java-8-oracle/jre/bin/java          1081      manual mode

Falls es bei Dir keinen speziellen Grund gibt, weswegen Du unbedingt Oracles Java nutzen musst, könntest Du mal auf die Position 2 wechseln. Damit funktioniert bei mir PP hervorragend.

1 Like

super, danke! - 2 und 3 funktionieren

Ich habe in dem parallelen Thread die Probleme zusammengefasst, die ich bisher sehe.

Wichtig: Ab dieser Version braucht PP Java 11.

1 Like