White areas of icons are displayed black

There is a little issue with the icons. White areas are displayed in black.

Correct. Having the same issues here as well with logos where any white colour is displayed in black colour. I tried different formats (.jpg and .png). Only little difference is if using a .png file with transparent background. Then, the background is displayed in a grid of white and light grey dots (similar to the draft mode of displaying a .png file with transparent background in a browser window).

What platform are you guys running? Can you link a sample icon/image that demonstrates the issue?

Hi @chrisaut

I am running PP version 0.47.1.202008171007 (Aug. 2020) on macOS Big Sur, Version 11.0 Beta, on iMac 5K model.

Never used the logo feature before I updated to Big Sur beta. Thus, I cannot say if the issue already existed before.

Please, look at this picture


where you can see the results for three different logos to illustrate the issue.

On the top (#1) I used a this logo (with transparent background)
image

The other one in the middle (#2) is with a logo with real white background (there is no difference whether format is .png or .jpg)
image

And the third one (#3) at the bottom is a logo with black background but white apple
image

BTW … the logo issue is already reported under Logo schwarzer Hintergrund … maybe the two threads could get combined somehow …

image

This is how the 3 Images you linked are rendered for me under Windows.
Just a stab in the dark, are you running dark mode (or whatever it’s called) under MacOS?

Edit:
" BTW … the logo issue is already reported under Logo schwarzer Hintergrund … maybe the two threads could get combined somehow …"

Yes, but that’s in the german speaking section so it’s not really a duplicate. Anyways, I wasn’t able to reproduce there either…

Nope, not using dark mode. Just switched on dark mode for a minute and assigned logos as well … no difference. In all other applications the logos are viewed correctly; browser, lightroom, photoshop, etc.

Like I have said in Logo schwarzer Hintergrund it seems happen when PP have to resize the image itself.

Example 1 from @genussnase
image

Best practice (on Linux and maybe Mac): resize the logos to a functionable size before you give it into PP

Thx @ProgFriese … was sure I already tried this yesterday but probably only with 128 x 128 as smallest size. Anyway, just tried it again and in fact any image with a size of either 16 x16 or 32 x 32 is displayed correctly (independent from its resolution, e.g. 144 px/inch or 300 px/inch and also independent whether it’s 8 bit, 16 bit or 32 bit).

Some core libraries got updated with the latest release. Does it still reproduce with that version?

1 Like

32x32 is the size used on Retina displays. Then PP does not have to resize using the SWT library.

This is how it looks on my Macbook macOS 10.15.6:

Unfortunately, my Macbook is not supported by Big Sur. Can you share a screenshot how it looks with the 0.48.* version? I had the SWT libraries updated.

About the first image: the background is not really transparent. I opened it in the image in an editor and the background is actually a black and grey colored. I have cut the left half of the apple and you can see that my editor displays transparency differently.

Moin @AndreasB,
Just tried with latest 0.48.1 release … aaaaaand whohoooo … all perfect! Thumbs up. :+1:
Independent from the size of the uploaded image all is displayed correctly. Images with real transparent background as well.
Here is a screenshot with 0.48.1 and the three different Apple logos …
Bildschirmfoto 2020-09-03 um 08.56.47
Thanks a lot for your work!