Mehrere Bugs unter Linux Ubuntu 16.04


#1

Hallo,

zu allererst möchte ich mich für dieses super geniale Tool bedanken! Ich benutze es oft und gerne! Ich nutze folgendes Setting:

Linux Ubuntu 16.04
Portfolio Performance 0.27.8
openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11)
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

Im Prinzip funktioniert alles, PP zeigt ebenfalls keine Fehler an. Hier nun meine zu meldende Bugs:

  • Wenn ich ein Wertpapier anlegen oder ändern will, bleibt der Reiter “Klassifizierung” leer. Keine Schaltflächen vorhanden.
  • In der Vermögensaufstellung bleibt die Spalte “Bestand” leer. Bei mouse-over bekomme ich den Wert angezeigt.
  • Sämtliche Tortendiagramme werden nicht angezeigt. Definition enthält Daten. Rebalancing ebenfalls. Baumkarte klappt. Flächendiagramm ebenfalls.

Sämtliche Fehler waren bereits vor dem letzten Update existent.

Ich hoffe ich kann dir mit meinem Feedback helfen. Gerne kann ich ggfs. Einstellungen für dich auf meinem System testen.

Viele Grüße
Daniel


#2

Hast du das Paket libwebkitgtk-1.0-0 installiert? Alternativ kann es an fehlenden Zugriffsrechten liegen. Ich hab ein ähnliches Verhalten hier bereits mal geschildert (Portfolio Performance unter Linux)

Vielleicht hilft es dir ja.

Viele Grüße


#3

Danke für deinen Tipp, habe es gerade getestet. Allerdings wie es scheint erfolglos, da libwebkitgtk-1.0-0 bereits installiert ist.

Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
»libwebkitgtk-1.0-0« ist bereits die neuste Version (2.4.11-0ubuntu0.1).
libwebkitgtk-1.0-0 wurde als manuell installiert festgelegt.
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
abigen bootnode evm freeglut3 kde-l10n-de kde-l10n-engb libargtable2-0 libboost-random1.58.0 libboost-regex1.58.0
libboost-thread1.58.0 libcryptopp-dev libethereum libjsoncpp1 libjsonrpccpp-client0 libjsonrpccpp-common0
libjsonrpccpp-server0 libleveldb1v5 libmicrohttpd10 linux-headers-4.10.0-28 linux-headers-4.10.0-28-generic
linux-image-4.10.0-28-generic linux-image-extra-4.10.0-28-generic miniupnpc puppeth rlpdump swarm wnode
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 51 nicht aktualisiert.


#4

Bei mir brauchte ich diese beiden:

dpkg -l | grep -i openjdk-8
ii openjdk-8-jre:amd64 8u131-b11-2ubuntu1.16.04.3 amd64 OpenJDK Java runtime, using Hotspot JIT
ii openjdk-8-jre-headless:amd64 8u131-b11-2ubuntu1.16.04.3 amd64 OpenJDK Java runtime, using Hotspot JIT (headless)

Hast Du die?


#5

Hallo sorry für die späte Antwort.

ii openjdk-8-doc 8u131-b11-2ubuntu1.16.04.3 all OpenJDK Development Kit (JDK) documentation
ii openjdk-8-jdk:amd64 8u131-b11-2ubuntu1.16.04.3 amd64 OpenJDK Development Kit (JDK)
ii openjdk-8-jdk-headless:amd64 8u131-b11-2ubuntu1.16.04.3 amd64 OpenJDK Development Kit (JDK) (headless)
ii openjdk-8-jre:amd64 8u131-b11-2ubuntu1.16.04.3 amd64 OpenJDK Java runtime, using Hotspot JIT
ii openjdk-8-jre-headless:amd64 8u131-b11-2ubuntu1.16.04.3 amd64 OpenJDK Java runtime, using Hotspot JIT (headless)

Die Module habe ich bereits…


#6

Da sollte erst mal nur ein “+” (Plus) zu sehen sein. Komisch. Wenn Du den Dialog in der Grösse - von ganz klein bis groß - veränderst, taucht dann was auf. Ich überlege was da am Layout schief geht.

Das Problem wird hin und wieder. Die Spalte ist mit einem sogenannte “OwnerDrawLabelProvider” gerendert der anscheinend manchmal Probleme bereitet.

Und das tritt auf meinem Linux Image einfach nicht auf (ich habe ein Standard Ubuntu 16.04 und 17.04 zum testen auf VMWare. Das macht es für mich schwer dem auf die Spur zu kommen. Wenn jemand mit Eclipse Wissen auf Linux hier aushelfen könnte, dann wäre das super.

Der Browser… Tortendiagramme werden mit dem Browser gerendert. Baumkarte und Flächendiagramm dagegen nicht. Ich vermute mal dass geht in diese Richtung: https://github.com/buchen/portfolio/issues/769 (nicht das ich wüsste wie ich das behebe…)


#7

Hallo Andreas,

besten Dank für deine Hinweise!
Zu Punkt 1: Das hat schon mal geklappt - sprich das Fenster Größer ziehen und siehe da, alles da wo es sein soll.
Zu 2 kann ich leider nichts sagen, aber vielleicht habe ich ja noch glück und jemand hat eine Idee
Zu 3 würde es was bringen einen anderen Browser noch zu installieren? Aktuell läuft nur Chrome auf meinem System.

Besten Dank für deine Hilfe!


#8

Leider hat das nix mit Chrome zu tun. :grimacing: Eclipse / SWT verwenden den XULRunner.

Wenn Du Dich versuchen möchtest: https://www.eclipse.org/swt/faq.php#browserlinux

Eclipse 4.5 and newer: Mozilla 1.4 GTK2 - 1.7.x GTK2, XULRunner 1.8.x - 1.9.x, 3.6.x, 10.x, 24.x and 31.x (but not 2.x nor other unlisted versions), WebKitGTK+ 1.2.x and newer (Note:Eclipse 4.5 support for XULRunner 31.x is not available on Linux due to Bug 467646.)