Neuinstallation des OS und PP: Reicht es das xml file zu sichern?

Hallo zusammen!
Ich nutze PP unter Linux Mint 19.3 und bin begeistert von dem Programm.
Ich möchte den Rechner aus anderen Gründen neu aufsetzen und danach PP wieder installieren.
Reicht es, die xml Datei zu sichern und nach der Neuinstallation zu öffnen?
Danke im Voraus!
Andreas

Im Prinzip reicht das - für die eigentlichen Daten. Noch schöner ist es auch einige Einstellungen mit zu sichern.
Unter Hilfe / Einstellungen / Allgemein einen Haken bei „GUI Einstellungen …“ setzen
Bildschirmfoto_2020-03-01_11-52-25
Dann wird Dir die Settings-Datei neben dem xml-File gespeichert, z.B.
~/PfadzumPP-File/foobar.xml
dann wird ein File namens
~/PfadzumPP-File/foobar.settings
gespeichert.

Diese Settings-Datei auch sichern und in der PP-Neuinstallation den GUI-Haken auch wieder setzen (vor dem Öffnen der xml).

Reicht es nicht einfach aus, das gesamte Verzeichnis zu zippen und auf den neuen Rechner zu kopieren? Voraussetzung die XML Daten sind im gleichen Verzeichnis wie PP. Dann könnte man alles bequem auf USB Stick transportieren.

Nein, da per Default PP keine Portable Version ist. Einstellungen werden außerhalb des PP Verzeichnis gespeichert.

hallo,

ich hab ein ähnliches problem.
bei mir ist die datei und „settings“ auch zusammen abgelegt und diese habe ich gesichert.

nach einer Neuinstallation habe ich einfach PP runter geladen und dann die datei geöffnet.
muss ich noch irgendwas mit den settings machen?

bei mir hat es nämlich schon einiges „zerschossen“. z.b. sind die zeiträume nicht mehr angegeben und im dashboard stimmen einige rechnungen usw. nicht mehr… :frowning:

PP sucht die „settings“ Datei neben der XML Datei wenn das entsprechend in den Einstellungen (siehe oben) konfiguriert ist.

Ist das in Deiner Neuinstallation vielleicht nicht der Fall und PP hat neue settings generiert?

Die Settings haben keinen Einfluß auf Berechnungen. Um das nachvollziehen bräuchte ich etwas mehr Details - welche Berechnung, was erwartest Du zu sehen, was steht da…

Dieser Beitrag wurde von der Community gemeldet und ist vorübergehend ausgeblendet.

Die settings liegen bei mir neben der XML.
Kann aber gut sein, dass neue settings angelegt wurden. Bin ich mir nicht sicher, aber was müsste man den konfigurieren?

Im Dashboard ist z.B. die monatliche prozentuale Anzeige komplett falsch. Sieht aus, als würden nicht mehr alle Depots mit in die Berechnung mit einfließen.
Außerdem ist überall die Ansicht usw. auf 1 Jahr eingestellt.