Fehlerhafte Graphdarstellung im Performance Diagramm


#1

Hallo,

danke für diese tolle Software. Ich weiß die Aufwände zu schätzen!

Vllt. habe ich auch nur ein Verständnisproblem, jedoch scheint mir das es ein Fehler im Performance Diagramm gibt.

Das Portfolio ist mit kleinen Ausrutschern durchweg positiv. Stellt man den Berichtszeitraum unter 1 Jahr (bspw. 1-11 Monate) wird der Graph richtig eingezeichnet. Wählt man als Zeiteinheit beliebige Werte größer-gleich einem Jahr egal ob 1 Jahr oder 365 Tage fällt der Graph direkt vollständig und überproportional ins Negative. Ist das ein Darstellungsfehler?


#2

Was ist denn an dem Tag passiert (Buchung), an dem die Performance so fällt?


#3

Bis auf das ich bei meinem allerersten Kauf den Anfängerfehler gemacht habe und für eine Ausführung eines Anteils 12,40€ Gebühren gezahlt habe, ist dort eigentlich nichts passiert. Normale Sparplan Ausführung und Einlagen.

Auch das gesamte Portfolio ist IMHO eigentlich im Plus bis auf natürlich die Position mit den 12,40 Gebühren. Die steht auf -16% TTWROR, Absolute Performance jedoch wieder auf +60. Siehe Screenshot


#4

Dann dürfte das das gleiche Thema sein wie hier:


#5

Ich verstehe aber nicht warum soetwas einen fast 30% negativen Performanceverlust bedeuten sollte. Alle Kennzahlen zeigen doch das die Performance Überwiegend positiv ist. Ist das nun ein Fehler in der Darstellung? Im Endeffekt sagt mir das Diagramm meine Performance wäre -15% obwohl es eigentlich im Depot super aussieht. Das hilft doch so keinem sein Portfolio zu managen?


#6

Bitte schau Dir einmal an, was die TTWROR aussagt und ob Du nicht lieber die IRR verwenden möchtest:

Ich kenne Deine exakten Buchungen nicht. Wenn Du magst, kannst Du ja mal einen Screenshot veröffentlichen oder ein Minimalbeispiel hochladen.

So wie ich Dich verstehe, hattest Du bei der ersten Sparplanausführung sehr hohe Gebühren. Die hohen Gebühren drücken kräftig auf die Rendite. Dass Du später nachgekauft hast, dabei weniger Gebühren bezahlt hast und die Performance insgesamt mittlerweile positiv ist, ignoriert die TTWROR.

Warum? Das ist die Definition der TTWROR. Sie gibt Dir vereinfacht gesagt an, wie die Performance gewesen wäre, wenn Du keine Nachkäufe gemacht hättest. Und aufgrund der hohen Gebühren, wäre Deine Rendite dann negativ.

Wenn Du die Zukäufe berücksichtigt haben möchtest, dann schau Dir lieber den internen Zinsfuß an.

Nicht jede Kennzahl ist in jedem Fall hilfreich. Muss und kann auch nicht so sein.


#7

Danke Dir, für deine Erklärung, ich lese mir die Threads/Infos mal durch. Das Angebot Dir mal ein paar Buchungen zu senden nehme ich gerne die Tage mal an.

Es wäre fine für mich auch IRR oder IZF zu verwenden, das kann ich aber doch nicht im Diagramm abbilden oder? Hier wird doch automatisch immer die TTWROR verwendet oder?


:sunny: Neues & Nennenswertes
#8

Hallo,
bin seit kurzen auch begeisterter PP-Nutzer, bin also kompletter Neuling!
Ich habe mich mal durch alle Threads zu dem Thema durchgelesen, die ich finden konnte, bin aber leider nicht schlauer geworden… Ich hatte anfangs einen Sparplan und habe dann nach kurzer Zeit einen größeren Kauf der gleichen ETFs des Sparplans getätigt. Nach dem Kauf stürzt die Rendite der ETFs ziemlich ab (erster eingemalter Kreis), was ich mir nicht erklären kann, da ich jedes Mal unter dem jetztigen Kurs gekauft habe (Kurs wird über die Tabelle von onviste.de übernommen und stimmt). Ich habe auch die Einlage immer einen Tag vor dem Kauf datiert (war glaub ich in einem Thread das Problem).

Zum zweiten Kringel: Da habe ich einen ETF nach ca. einem halben Jahr mit positiver Rendite (um die ca. 5%), jedoch gibt es auch da einen Absturz bis zur Rendite -100% den ich mir nicht erklären kann.

Bin ich einfach nur dumm oder ist das irgendein Fehler? Wenn ich dumm bin, woran könnte es liegen? Und wenn es ein Fehler ist, wie kann man ihn beheben?

Viele Grüße
Peter


#9

Es könnte sich um das obige Thema handeln: die “Verluste” des grösseren, zweiten Kaufs werden an dem Tag selber dem bisherigen Kapital (also der relativ kleinen Position) zugeordnet. Wenn man nur einen Verlust von 10 Euro Gebühren hat, kann das bei einer kleinen Position von 100 Euro schon viel ausmachen.

Wie gesagt - die Idee ist das zu ändern - allein noch nicht implementiert: https://github.com/buchen/portfolio/issues/615

Mmmmh. :thinking: ich hatte mal einen Rechenfehler bei dem die Performance auf -1 (also -100%) fällt. Der sollte eigentlich weg sein. Um da was näher zu sagen, bräuchte irgendwie mehr Daten - welche Buchungen haben da stattgefunden?, wie ist die Datenreihe aufgebaut?


#10

Richtige Datenreihe gibt es da nicht: Am 10.08.2016 für 2005,80€ gekauft und am 18.01.2017 für 2115,20€ verkauft. Das wars.
Ein Tag nach dem Kauftag aber entsteht der Absturz, geht von ca. 6% auf -100% runter. Ist das ein Feature? Eigentlich sollte die Linie ja dann aufhören oder grade weitergehen :thinking: .


#11

Hat denn schon hier jemand eine Lösung gefunden das Problem zu umgehen?


#12

Schau Dir mal den Kommentar auf Github an und gib mal Feedback ob das so besser passt.


#13

Hallo nochmal,

ich habe mit Freude vernommen das laut Release Notes zur 0.27.x der Fehler in der Graphdarstellung korrigiert sein sollte. Ich habe das gleich mal gecheckt ohne Erfolg. Bei mir schießt der Graph immernoch vollständig in den Keller wenn ich diesen einen Aktienkauf im Zeitstrahl mit einbeziehe. Auch der MSCI World ETF den ich als Benchmark gestrichelt eingezeichnet verläuft auf einmal gleichermaßen fehlerhaft. Ich kann mir das nicht erklären.

LG
Alex


#14

Kannst Du mal eine Beispiel hoch laden? Oder an portfolio dot performance dot help at gmail dot com schicken? (Einfach alle anderen Wertpapiere / Konten / Buchungen löschen - solange der Effekt zu sehen bleibt)


#16

Ich hatte Dir ein Beispiel per E-Mail gesendet, ist das angekommen?

LG
Alex


#17

Ooops. Sorry, das muss irgendwie in meiner Mailbox untergegangen sein. Und ganz auf die Schnelle finde ich das gerade auch nicht. :disappointed: Noch mal? :relieved:


#18

Hallo Andreas,

ist die Mail nun angekommen? Absender alex at techtical dot net

LG
Alex